Opened 2 years ago

Closed 2 years ago

#23618 closed defect (duplicate)

"Bug: tor_compress_process: Non-fatal assertion"

Reported by: torvlnt33r Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.2.1-alpha
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by nickm)

Getting many such messages since upgrading to Tor 0.3.2.1-alpha, on a client connected to a bridge running 0.3.2.1-alpha too:

Sep 21 21:00:16.000 [warn] tor_bug_occurred_(): Bug: ../src/common/compress.c:576: tor_compress_process: Non-fatal assertion !((rv == TOR_COMPRESS_OK) && *in_len == in_len_orig && *out_len == out_len_orig) failed. (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug: Non-fatal assertion !((rv == TOR_COMPRESS_OK) && *in_len == in_len_orig && *out_len == out_len_orig) failed in tor_compress_process at ../src/common/compress.c:576. Stack trace: (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(log_backtrace+0x43) [0x557e14f28ba3] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x557e14f43cd9] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(tor_compress_process+0x14b) [0x557e14f4d50b] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(+0x1a7745) [0x557e14f4d745] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(tor_uncompress+0x31) [0x557e14f4dc01] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(connection_dir_reached_eof+0x1211) [0x557e14ed9301] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(+0x10b259) [0x557e14eb1259] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(+0x51f0e) [0x557e14df7f0e] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.1.so.6(+0x229ba) [0x7f9a861109ba] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.1.so.6(event_base_loop+0x5a7) [0x7f9a86111537] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(do_main_loop+0x28d) [0x557e14df8e5d] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(tor_main+0xe1d) [0x557e14dfbc6d] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(main+0x19) [0x557e14df4699] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7f9a849032e1] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] Bug:     /usr/bin/tor(_start+0x2a) [0x557e14df46ea] (on Tor 0.3.2.1-alpha )
Sep 21 21:00:16.000 [warn] More info on the bug: method == Zstandard compressed, finish == 0,  *in_len == in_len_orig == 2878, *out_len == out_len_orig == 0

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by torvlnt33r

(exactly every minute)

comment:2 Changed 2 years ago by nickm

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Thanks for reporting this! It looks like a duplicate of #23551 .

Note: See TracTickets for help on using tickets.