Opened 2 years ago

Closed 2 years ago

#23646 closed defect (duplicate)

Undefined References to Panning functions (for Tom Ritter)

Reported by: cypherpunks Owned by: tom
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is https://bugzilla.mozilla.org/show_bug.cgi?id=1402385.
The reason is https://bugzilla.mozilla.org/show_bug.cgi?id=1391164.
Now C functions are called as C++ (without extern "C").

Child Tickets

Change History (5)

comment:1 Changed 2 years ago by cypherpunks

Component: - Select a componentApplications/Tor Browser
Owner: set to tom
Status: newassigned

comment:2 Changed 2 years ago by cypherpunks

Hrm, does this notify Tom?

comment:3 Changed 2 years ago by tom

It does, sorry I missed the detail in this ticket the other day. Thanks for showing me the root cause!

comment:4 Changed 2 years ago by cypherpunks

Just for clarification, what comment does (first/second)? Or both?
So, does adding extern "C" (extern "C" BeginPanningFeedback(hWnd), etc) fix the problem?

comment:5 Changed 2 years ago by gk

Resolution: duplicate
Status: assignedclosed

No need to track this in our bug tracker I think. Jacek has a patch for this mingw-w64 bug which should make it into the repository pretty soon: https://bugzilla.mozilla.org/show_bug.cgi?id=1402385#c4.

Resolving this as duplicate of Mozilla's 1402385.

Note: See TracTickets for help on using tickets.