Opened 16 months ago

Last modified 11 months ago

#23701 needs_information defect

Lower parts of letters get eaten by making line-height uniform

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, tbb-fingerprinting-os
Cc: igt0 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In #23104 we tried to make the line height uniform in order to avoid operating system fingerprinting. It seems that affects some systems in a way that lower parts of letters in the URL bar are eaten:

https://blog.torproject.org/tor-browser-75a5-released#comment-271522

Child Tickets

Change History (9)

comment:1 Changed 16 months ago by gk

I wonder whether that would get solved by making sure the patch only applies to content and not the chrome parts.

comment:2 Changed 16 months ago by cypherpunks

Text drifts slightly in the Browser Console. Is this because of this feature?

comment:3 in reply to:  2 Changed 16 months ago by gk

Replying to cypherpunks:

Text drifts slightly in the Browser Console. Is this because of this feature?

Could be if you are using 7.5a5. You could test whether disabling fingerprinting resistance fixes the issue for you (this feature, as many other fingerprinting related ones, is bound to privacy.resistFingerprinting which we set to true).

comment:4 Changed 16 months ago by gk

Resolution: fixed
Status: newclosed

Should be "fixed" by backing out the patch for #23104 until we have a better solution.

comment:5 in reply to:  2 ; Changed 11 months ago by cypherpunks

Resolution: fixed
Status: closedreopened

In content: https://dxr.mozilla.org

Replying to cypherpunks:

Text drifts slightly in the Browser Console. Is this because of this feature?

Confirmed.

comment:6 in reply to:  5 Changed 11 months ago by igt0

Status: reopenedneeds_information

Did you try the experimental tor browser? I am not able to reproduce the problem there. (However it is reproducible in the latest stable build 7.5.x).

Replying to cypherpunks:

In content: https://dxr.mozilla.org

Replying to cypherpunks:

Text drifts slightly in the Browser Console. Is this because of this feature?

Confirmed.

comment:7 Changed 11 months ago by cypherpunks

Status: needs_informationnew

Kidding? They are identical in that regard.

comment:8 in reply to:  7 Changed 11 months ago by igt0

And just to make sure we are in the same page, when the JavaScript is disabled (noscript), the page content doesn't render properly. Even in Firefox Quantum.

Replying to cypherpunks:

Kidding? They are identical in that regard.

comment:9 in reply to:  5 Changed 11 months ago by gk

Status: newneeds_information

Replying to cypherpunks:

In content: https://dxr.mozilla.org

What do you mean? Which operating system are you on? Could you add a screenshot showing your problem?

Note: See TracTickets for help on using tickets.