Opened 12 months ago

Closed 5 months ago

#23715 closed enhancement (fixed)

Support `memfd_create(2)`

Reported by: yawning Owned by: dgoulet
Priority: Medium Milestone:
Component: Core Tor/Torsocks Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Enough things use this now that it's probably sensible to support this in the syscall(2) wrapper.

Child Tickets

Change History (3)

comment:1 Changed 12 months ago by yawning

Status: newneeds_review

comment:2 Changed 12 months ago by yawning

Ok, just tested it since my mail client trivially reproduces the warning. Works fine.

comment:3 Changed 5 months ago by dgoulet

Resolution: fixed
Status: needs_reviewclosed

Merged! Thanks!

Note: See TracTickets for help on using tickets.