Opened 2 years ago

Closed 2 years ago

#23730 closed defect (not a bug)

Change profile location

Reported by: bitwyse Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: Profiles
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello
I have always used Tor with the program on one partition and the profile on another.
I simply copied the profile whare I wanted it and changed profiles.ini to
IsRelative=0
Path=[absolute path]
That worked fine and I kept my usual settings after updates.

I just updated to 7.0.6 and that doesn't work any more.

  • if I do as above it "cannot start" (or if it does it complains that the proxy settings are wrong - although I set "no proxy").
  • if I use Profile Manager to create a new profile Tor is in English, although my installer version is French - and a lot of things are missing from the new profile.

Can anyone tell me how to get round this?

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by dgoulet

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 2 years ago by mcs

Status: newneeds_information

Thanks for reporting this problem. It sounds like you are using an unusual configuration, but I can try to help. Please answer the following questions:

  • What operating system are you using?
  • What version of Tor Browser did this last work in?
  • If you start with a completely new Tor Browser (without trying to reuse your old profile), are you able to move the profile to a new location and use it?

Also, please avoid creating a new profile using the Profile Manager unless you are macOS. It won't work correctly in Tor Browser on Windows or Linux.

Last edited 2 years ago by mcs (previous) (diff)

comment:3 Changed 2 years ago by bitwyse

Thanks for your reply and offer to help!

  • OS = Windows XP Pro SP3
  • Last version with which it worked: 7.0.2 (haven't tried any other in between). It worked with all previous versions (for years).
  • I can move the whole programme folder (with the default profile included) anywhere and it works fine. But I can't move the new default profile either (I did try that) - it won't start, with the error "cannot connect to control port". The control ports are open in my firewall which doesn't seem to mind where Tor is (and it still happens even if I switch the firewall off).

(The reason for this configuration is that I keep the system, programmes and data all on different partitions).

Regards

Last edited 2 years ago by bitwyse (previous) (diff)

comment:4 Changed 2 years ago by mcs

Resolution: not a bug
Status: needs_informationclosed

We investigated this a bit more. I'm not sure why it used to work, but relocating the profile is not a configuration that we can support at this time. That said, I was able to get a configuration similar to yours to work by copying the directory Browser\TorBrowser\Data\Tor to the alternate location (in addition to copying profile.default). In my case I copied it to D:\tordata\

Then I had to add the following preference string values using about:config:

extensions.torlauncher.tordatadir_path=d:\\tordata
extensions.torlauncher.torrc_path=d:\\tordata\torrc
extensions.torlauncher.torrc-defaults_path=d:\\tordata\torrc-defaults

The reason this is difficult for us to support is because our automatic update mechanism as well as other browser code assumes that all of the user data is embedded within the application area. See #18367 for a ticket that, if fixed, would move us closer to being able to support the configuration you want to use.

Note: See TracTickets for help on using tickets.