#23765 closed defect (worksforme)

oniongit CI test runner out of disk?

Reported by: catalyst Owned by: tor-gitadm
Priority: Medium Milestone:
Component: Internal Services/Service - git Version:
Severity: Normal Keywords: tor-ci
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It looks like the CI runner on oniongit is out of disk space:

Preparing to unpack .../libglib2.0-0-refdbg_2.42.1-1+b1_amd64.deb ...
Unpacking libglib2.0-0-refdbg:amd64 (2.42.1-1+b1) ...
dpkg: error processing archive /var/cache/apt/archives/libglib2.0-0-refdbg_2.42.1-1+b1_amd64.deb (--unpack):
 cannot copy extracted data for './usr/lib/x86_64-linux-gnu/refdbg/libgobject-2.0.so.0.4200.1' to '/usr/lib/x86_64-linux-gnu/refdbg/libgobject-2.0.so.0.4200.1.dpkg-new': failed to write (No space left on device)
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for systemd (215-17+deb8u7) ...
dpkg: error: failed to write status database record about 'mono-gac' to '/var/lib/dpkg/status': No space left on device
E: Sub-process /usr/bin/dpkg returned an error code (2)
ERROR: Job failed: exit code 1

Or maybe that's just the Docker container? I can't tell.

Child Tickets

Change History (2)

comment:1 Changed 19 months ago by catalyst

Status: newneeds_information

After removing asciidoc (which installs texlive, which is enormous) from the dependencies, the CI jobs seem to run. Maybe no change is necessary at this time.

comment:2 Changed 18 months ago by Sebastian

Resolution: worksforme
Status: needs_informationclosed

I'm going to close this as can't reproduce, please file it as a sys admin ticket if it happens again

Note: See TracTickets for help on using tickets.