Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#2377 closed defect (fixed)

Gmail login claims cookies are disabled.

Reported by: mikeperry Owned by: mikeperry
Priority: Very High Milestone:
Component: Applications/Torbutton Version:
Severity: Keywords:
Cc: the.magical.kat@… Actual Points: 4
Parent ID: Points: 6
Reviewer: Sponsor:

Description

The gmail login page is sometimes claiming that cookies are disabled even when they are not.

This issue is caused by the hidden setting: extensions.torbutton.xfer_google_cookies.

This setting was introduced to reduce the number of captchas that google presented, so that you would only have to solve a captcha once, instead of once per country code domain.

We need to investigate exactly why this cookie transfer is now breaking the login process. Something must have changed with the cookie names/origins/etc.

Child Tickets

Attachments (1)

torbutton-1.3.2pre-alpha3.xpi (469.7 KB) - added by mikeperry 9 years ago.
Limit the Google Captcha cookies transfered between domains.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by mikeperry

Points: 6

Reproduce: 3
Fix: 3

comment:2 Changed 9 years ago by katmagic

Cc: the.magical.kat@… added

This bug is extremely confusing. Perhaps extensions.torbutton.xfer_google_cookies should be set to false by default until it's fixed?

Changed 9 years ago by mikeperry

Limit the Google Captcha cookies transfered between domains.

comment:3 Changed 9 years ago by mikeperry

Katmagic: Can you give that XPI a whirl? It seems to work for me, but the issue seems random and erratic to reproduce.

comment:4 Changed 9 years ago by katmagic

mikeperry: It works! :-)

comment:5 Changed 9 years ago by mikeperry

Actual Points: 4
actualpointsdone: 4
pointsdone: 6
Resolution: fixed
Status: newclosed

comment:6 Changed 8 years ago by xerces8

I just experienced this with tor-browser-1.3.26_en-US.exe (using torbutton v1.2.5)

I disabled xtensions.torbutton.xfer_google_cookies (set to false) and then it worked.

comment:7 in reply to:  6 Changed 8 years ago by rransom

Replying to xerces8:

I just experienced this with tor-browser-1.3.26_en-US.exe (using torbutton v1.2.5)

See #3691.

Note: See TracTickets for help on using tickets.