Opened 2 years ago

Closed 2 years ago

#23772 closed defect (invalid)

HTTPS Everywhere restartless updates join the scene

Reported by: cypherpunks Owned by: legind
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

1507202782600	addons.webextension.<unknown>	WARN	Loading extension 'null': Reading manifest: Error processing devtools_page: An unexpected property was found in the WebExtension manifest.
1507202784900	addons.xpi	WARN	Add-on https-everywhere-eff@eff.org is missing bootstrap method uninstall
1507202785200	addons.xpi	WARN	Add-on https-everywhere-eff@eff.org is missing bootstrap method install
Bootstrapped manifest not allowed to use 'component' directive.  chrome.manifest:60
Bootstrapped manifest not allowed to use 'contract' directive.  chrome.manifest:61
Bootstrapped manifest not allowed to use 'category' directive.  chrome.manifest:63
Bootstrapped manifest not allowed to use 'overlay' directive.  chrome.manifest:68
Bootstrapped manifest not allowed to use 'overlay' directive.  chrome.manifest:69
Bootstrapped manifest not allowed to use 'style' directive.  chrome.manifest:71
Bootstrapped manifest not allowed to use 'component' directive.  chrome.manifest:74
Bootstrapped manifest not allowed to use 'contract' directive.  chrome.manifest:75
Bootstrapped manifest not allowed to use 'category' directive.  chrome.manifest:76
1507202785500	addons.xpi	WARN	Failed to remove temporary file C:\Users\X\AppData\Local\Temp\tmp-1xc.xpi for addon https://www.eff.org/files/https-everywhere-2017.10.4-eff.xpi: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm :: removeTemporaryFile :: line 5598"  data: no] Stack trace: removeTemporaryFile()@resource://gre/modules/addons/XPIProvider.jsm:5598 < startInstall/<()@resource://gre/modules/addons/XPIProvider.jsm:6027 < Handler.prototype.process()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:932 < this.PromiseWalker.walkerLoop()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813 < this.PromiseWalker.scheduleWalkerLoop/<()@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747
Use of nsIFile in content process is deprecated.  Content.js:26:17
1507202786200	addons.webextension.https-everywhere-eff@eff.org	WARN	Loading extension 'https-everywhere-eff@eff.org': Reading manifest: Error processing devtools_page: An unexpected property was found in the WebExtension manifest.
1507202786400	addons.webextension.https-everywhere-eff@eff.org	WARN	Please specify whether you want browser_style or not in your browser_action options.
Hey developer! Want to see more verbose logging?  util.js:16:1
Type this into the console: DEFAULT_LOG_LEVEL=VERB  util.js:17:1
Accepted levels are VERB, DBUG, INFO, NOTE and WARN, default is NOTE  util.js:18:1
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/  util.js:40:2
XML Parsing Error: syntax error
Location: jar:file:///C:/Tor%20Browser/Browser/TorBrowser/Data/Browser/profile.default/extensions/https-everywhere-eff@eff.org.xpi!/webextension/rules/default.rulesets
Line Number 1, Column 1:  default.rulesets:1:1
XML Parsing Error: no root element found
Location: moz-extension://bd161ca7-4e6f-414e-b112-56b0d3c6f86f/_generated_background_page.html
Line Number 1, Column 1:  _generated_background_page.html:1:1

Child Tickets

Change History (8)

comment:1 Changed 2 years ago by gk

Status: newneeds_information

What bug are you experiencing? Could you describe it in some words and give some steps to reproduce?

comment:2 Changed 2 years ago by cypherpunks

Status: needs_informationnew

Almost every line above is a bug.
Actually, only two guys complained when HTTPSE was entirely broken recently (out of ~2M!), so I don't give a fuck about it too.
It's up to developers whether to fix these bugs or not.
restartless update is STR.

comment:3 in reply to:  2 Changed 2 years ago by cypherpunks

Status: newneeds_information

Replying to cypherpunks:

Almost every line above is a bug.
Actually, only two guys complained when HTTPSE was entirely broken recently (out of ~2M!), so I don't give a fuck about it too.
It's up to developers whether to fix these bugs or not.
restartless update is STR.

Is there something that TB developers can do to fix some of these bugs or all of them should be handled by HTTPSE devs?

comment:4 Changed 2 years ago by cypherpunks

Status: needs_informationnew

TB = Thunderbird ;)
Devs can add legind to cc, for example, and also help him to fix bugs, of course.

09:09:19.751 NS_BINDING_ABORTED: Component returned failure code: 0x804b0002 (NS_BINDING_ABORTED) [nsIStreamListener.onDataAvailable] WebRequest.jsm:355

from HTTPSE.

comment:5 in reply to:  4 ; Changed 2 years ago by cypherpunks

Replying to cypherpunks:

TB = Thunderbird ;)

TBB is a deprecated name ;^)

comment:6 in reply to:  5 Changed 2 years ago by cypherpunks

Status: newneeds_revision

Hey developers!
Your WebExtension (version 2017.10.4.1337) is the same as embedded in bootstrapped extension (version 2017.10.4) and with the same bugs ;) Some of them:

NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindowUtils.isParentWindowMainWidgetVisible]  nsPrompter.js:350
Error: Script terminated by timeout at:
RuleSets.prototype.parseOneJsonRuleset@moz-extension://0bd5babd-e06e-4095-9c3e-ffc4e826e141/rules.js:299:5
RuleSets.prototype.addFromJson@moz-extension://0bd5babd-e06e-4095-9c3e-ffc4e826e141/rules.js:233:9
RuleSets.prototype.initialize@moz-extension://0bd5babd-e06e-4095-9c3e-ffc4e826e141/rules.js:211:5
initialize@moz-extension://0bd5babd-e06e-4095-9c3e-ffc4e826e141/background.js:10:9
  rules.js:299:5
05:15:00.373 uri is undefined 1 MatchPattern.jsm:95        
matches resource://gre/modules/MatchPattern.jsm:95:1
matches/< resource://gre/modules/MatchPattern.jsm:118:42
some self-hosted:208:1
matches resource://gre/modules/MatchPattern.jsm:118:12
urlMatches resource://gre/modules/WebRequestCommon.jsm:55:12
shouldRunListener resource://gre/modules/WebRequest.jsm:549:12
runChannelListener resource://gre/modules/WebRequest.jsm:692:14
errorCheck resource://gre/modules/WebRequest.jsm:568:7
runChannelListener resource://gre/modules/WebRequest.jsm:676:20
onStopRequest resource://gre/modules/WebRequest.jsm:841:5
onStopRequest resource://gre/modules/WebRequest.jsm:351:5

Is there any reason to postpone switching to it?

Replying to cypherpunks:

Replying to cypherpunks:

TB = Thunderbird ;)

TBB is a deprecated name ;^)

Until Tor is integrated, it's bundled ;)

comment:7 Changed 2 years ago by gk

Component: Applications/Tor BrowserHTTPS Everywhere/EFF-HTTPS Everywhere
Owner: changed from tbb-team to legind
Status: needs_revisionassigned

comment:8 Changed 2 years ago by legind

Resolution: invalid
Status: assignedclosed

This bug isn't specific enough, and we track HTTPS Everywhere issues at https://github.com/EFForg/https-everywhere/

Note: See TracTickets for help on using tickets.