#23780 closed defect (fixed)

Tor repeatedly tells me that "Your Guard is failing an extremely large amount of circuits" when using snowflake

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Circumvention/Snowflake Version: Tor: 0.3.2.9
Severity: Normal Keywords:
Cc: dcf, arlolra Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Of course, Snowflake works and I have no idea why the guard must be failing. Moreover, it says that message right after the 85% in the bootstrap and 90%:

[notice] Bootstrapped 80%: Connecting to the Tor network
[notice] Bootstrapped 85%: Finishing handshake with first hop
[warn] Your Guard [scrubbed] is failing an extremely large amount of circuits. This could indicate a route manipulation attack, extreme network overload, or a bug. Success counts are 50/169. Use counts are 73/76. 162 circuits completed, 1 were unusable, 112 collapsed, and 4 timed out. For reference, your timeout cutoff is 60 seconds.
[notice] Tor has successfully opened a circuit. Looks like client functionality is working.
[notice] Bootstrapped 100%: Done
[warn] Your Guard [scrubbed] is failing a very large amount of circuits. Most likely this means the Tor network is overloaded, but it could also mean an attack against you or potentially the guard itself. Success counts are 52/171. Use counts are 73/76. 164 circuits completed, 1 were unusable, 112 collapsed, and 4 timed out. For reference, your timeout cutoff is 60 seconds.

Child Tickets

Change History (12)

comment:1 Changed 20 months ago by dcf

Cc: dcf added

comment:2 Changed 20 months ago by cypherpunks

Version: Tor: 0.3.2.1-alpha

Precising the version of little-t-tor in which this happened

comment:3 Changed 19 months ago by cypherpunks

Version: Tor: 0.3.2.1-alphaTor: 0.3.2.2-alpha

comment:4 Changed 16 months ago by cypherpunks

Version: Tor: 0.3.2.2-alphaTor: 0.3.2.9

Still happens.

Your Guard [scrubbed] is failing an extremely large amount of circuits. This could indicate a route manipulation attack, extreme network overload, or a bug. Success counts are 54/180. Use counts are 60/64. 169 circuits completed, 2 were unusable, 113 collapsed, and 7 timed out. For reference, your timeout cutoff is 60 seconds.

comment:5 Changed 16 months ago by dcf

If I had to guess, I would say that this is caused either by the temporary browser proxies being unreliable, or the few fallback round-the-clock proxies being unreliable. The go-webrtc binding has a known memory leak (#23749) that affects the standalong proxy code too; arlolra and I debugged it but haven't fixed it yet. If this message isn't preventing you from browsing, then it's probably nothing to be worried about.

comment:6 Changed 15 months ago by arlolra

Cc: arlolra added

comment:7 Changed 15 months ago by arlolra

Tor repeatedly tells me that "Your Guard is failing an extremely large amount of circuits" when using snowflake

This is only while bootstrapping, right?

comment:8 in reply to:  7 Changed 15 months ago by cypherpunks

Replying to arlolra:

This is only while bootstrapping, right?

Yeah.

comment:9 Changed 15 months ago by dcf

Not sure if it's related, but when I restarted the bridge just now, I got in the server's tor log:

Mar 12 21:36:56.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Mar 12 21:36:56.000 [notice] Your Guard [scrubbed] is failing more circuits than usual. Most likely this means the Tor network is overloaded. Success counts are 182/292. Use counts are 61/61. 282 circuits completed, 0 were unusable, 100 collapsed, and 128 timed out. For reference, your timeout cutoff is 60 seconds.
Mar 12 21:36:56.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Mar 12 21:36:56.000 [notice] Bootstrapped 100%: Done

comment:10 Changed 14 months ago by dcf

It's looking like the cause of this may have been unreliable standalone proxies--they were frequently crashing and being restarted. See comment:39:ticket:21312.

But that should be fixed now: see comment:57:ticket:21312.

So if you can, please try snowflake again and see if you continue to get the "Your Guard is failing an extremely large amount of circuits".

You will need to unpack a fresh copy of the browser, because the information about failed circuits is cached in the state file. You can try this build, which I just made for #25579.

https://people.torproject.org/~dcf/pt-bundle/snowflake/20180321-8.0a4-4a5889af2891/

comment:11 Changed 14 months ago by dcf

Status: newneeds_information

comment:12 Changed 14 months ago by cypherpunks

Resolution: fixed
Status: needs_informationclosed

So this is what I did:

  1. Download and extract your build.
  2. Replace my older snowflake-client with the one in your build.
  3. Delete the state file.
  4. ./start-tor-browser --debug

And I did no see those errors! So looks like it's been fixed. Also memory usage is much much better! Great job snowflake team! :D

Note: See TracTickets for help on using tickets.