Opened 2 years ago

Closed 2 years ago

#23788 closed defect (not a bug)

When I host a V3 hidden service using macOs server it requires me to have "https" in front of the onion so that it lets me connect

Reported by: Dbryrtfbcbhgf Owned by:
Priority: High Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I host a V3 hidden service using macOs server it requires me to have "https" in front of the onion so that it lets me connect.
Example.

This does Not work
ore6heql7pvadxhb3csr2ljzr7pkqfl4m3snepqafwqovm6zt7i2pnad.onion

This Does work
https://ore6heql7pvadxhb3csr2ljzr7pkqfl4m3snepqafwqovm6zt7i2pnad.onion
tested on Tor 0.3.2.2-alpha

Steps.
start a web server on local port 443.
set the torrc to "HiddenServicePort 443 10.0.1.32:443"
start tor.
Connect to the hidden service using ore6heql7pvadxhb3csr2ljzr7pkqfl4m3snepqafwqovm6zt7i2pnad.onion
and it does not work unless I use https://ore6heql7pvadxhb3csr2ljzr7pkqfl4m3snepqafwqovm6zt7i2pnad.onion

Child Tickets

Change History (1)

comment:1 Changed 2 years ago by arma

Resolution: not a bug
Status: newclosed

This is not surprising. You set your service up on port 443, so of course you need to reach it on 443.

If you had set it up on 80, you would need to reach it on 80.

Note: See TracTickets for help on using tickets.