Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#23836 closed defect (not a bug)

spurious warning about used nickname

Reported by: toralf Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.2.2-alpha
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm wondering why I suddenly got at both of my 2 Tor exit relays (0.3.2.2.-alpha, running at the same machine) the following message:

/tmp/notice2.log:Oct 07 22:41:58.000 [warn] You specified a relay "zwiebeltoralf2" by name, but nicknames can be used by any relay, not just the one you meant. To make sure you get the same relay in the future, refer to it by key, as "$6EABEBF38CE7E3DF672C4DB01383606FE3EB2215".

/tmp/notice.log:Oct 07 22:39:53.000 [warn] You specified a relay "zwiebeltoralf" by name, but nicknames can be used by any relay, not just the one you meant. To make sure you get the same relay in the future, refer to it by key, as "$1AF72E8906E6C49481A791A6F8F84F8DFEBBB2BA".

when I queried the Tor status via a home-brewed Python script [1]. I do assume that the message is related to line 90 ot that script:

flags = controller.get_network_status(relay=srv.nickname).flags

[1] https://github.com/toralf/torutils/blob/master/info.py

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by toralf

Well, circumvent it by the issue by :
https://github.com/toralf/torutils/commit/e98f6a5c82fe1317cfd017195f6926a69e23ee9f
But still do wonder why this message appears nowadays.

comment:2 Changed 2 years ago by nickm

Resolution: not a bug
Status: newclosed

I don't think this message is wrong. It's totally possible for there to be two relays in the consensus named "zwiebeltoralf2" -- anybody can sign up a relay with any nickname they want, and nothing prevents that. If you want to identify a relay uniquely, you need to use its fingerprint.

I'm closing this as "not a bug", but please reopen if there is something I am missing.

comment:3 Changed 2 years ago by toralf

yeah, the warning is fully ok
I was just wondering, what git commit between 0.3.1.7 and 0.3.2.2-alpha caused that and why that warning doesn't appear always when I run that Python script, but just sometimes.

comment:4 Changed 2 years ago by nickm

I think that the relevant patch was #5847 ; I think the warning is rate-limited, to avoid spamming your logs.

Note: See TracTickets for help on using tickets.