Opened 2 years ago

Closed 2 years ago

#23837 closed defect (duplicate)

Tor crashing after clicking "Cancel" in file download dialog

Reported by: requirement Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Steps to reproduce:

  • log in to your ProtonMail account
  • go to Settings -> Keys
  • click on "PUBLIC KEY" to download it
  • as soon as the dialog pop up, click "Cancel"
  • tor will Crash

Information:
Happened both on Windows 10 and Linux openSUSE.
Fully updated Tor Browser 7.0.6 with no custom addons.
I asked my friend from another country to check it and she confirmed it.

Worth mentioning is that when I actually click "Download" instead of "Cancel" the download never finishes. In Downloads there's "unknown time remaining" with 0 B/s. That might be actually ProtonMail's bug but I first wanted to report the Tor crash because if not being able to download the key is ProtonMail's bug and it caused Tor bug and they fixed it, we might not be able to reproduce Tor bug anymore.

Child Tickets

Attachments (1)

crash log.rtf (79.5 KB) - added by Dbryrtfbcbhgf 2 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 years ago by nickm

Component: Core Tor/TorApplications/Tor Browser
Owner: set to tbb-team

Changed 2 years ago by Dbryrtfbcbhgf

Attachment: crash log.rtf added

comment:2 Changed 2 years ago by Dbryrtfbcbhgf

Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:3 Changed 2 years ago by Dbryrtfbcbhgf

Priority: MediumHigh
Severity: NormalMajor

comment:4 Changed 2 years ago by cypherpunks

Keywords: tbb-crash added; crash removed
Version: Tor: 0.3.1.7

Interesting, #22610 seemed to fix this issue... At least for me I could no longer reproduce it. (Tested with the case mentioned in #22610, and not with ProtonMail, but something strange that I had noticed was that I could no longer use pdfjs to read both online and local PDF files and I'm always met with the external helper app warning, maybe this is a NoScript related issue or change again?)

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:5 in reply to:  4 Changed 2 years ago by Dbryrtfbcbhgf

Replying to cypherpunks:

Interesting, #22610 seemed to fix this issue... At least for me I could no longer reproduce it. (Tested with the case mentioned in #22610, and not with ProtonMail, but something strange that I had noticed was that I could no longer use pdfjs to read both online and local PDF files and I'm always met with the external helper app warning, maybe this is a NoScript related issue or change again?)

The crash also occurs on Noscript 5.1.2rc6

comment:6 Changed 2 years ago by cypherpunks

Status: newneeds_information

This has been fixed in #22618 although the patch didn't make to the 7.0.x series yet, can you test to confirm with a Tor Browser 7.5a5 install?

comment:7 in reply to:  6 Changed 2 years ago by Dbryrtfbcbhgf

Replying to cypherpunks:

This has been fixed in #22618 although the patch didn't make to the 7.0.x series yet, can you test to confirm with a Tor Browser 7.5a5 install?

Your correct, the crash does not occur on 7.5a5.

comment:8 Changed 2 years ago by Dbryrtfbcbhgf

Resolution: duplicate
Status: needs_informationclosed

Duplicate of #22618

Note: See TracTickets for help on using tickets.