Opened 10 months ago

Closed 3 months ago

Last modified 2 months ago

#23840 closed defect (fixed)

Google's reCAPTCHA fails 100%

Reported by: cypherpunks Owned by: hiro
Priority: Immediate Milestone:
Component: Community/Tor Support Version:
Severity: Blocker Keywords: cloudflare, google, captcha, noscript
Cc: fdsfgs@… Actual Points:
Parent ID: #18361 Points:
Reviewer: Sponsor:

Description

When I click "I;m not a robot" of Google Captcha, I instantly got:

Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page

Switching identity didn't help. Looks like Google ban Tor completely.
This will block Tor users to:
a) use web services which use Google Captcha (reddit registration for example)
b) visit Cloudflared website

You should write a blog to gather attention.

Child Tickets

Attachments (3)

1.png (68.0 KB) - added by tokotoko 10 months ago.
this?
02-11-2017_14:24:34.png (162.2 KB) - added by tokotoko 10 months ago.
vultr
e-hentai_recaptcha.png (75.9 KB) - added by tokotoko 9 months ago.

Download all attachments as: .zip

Change History (74)

comment:1 Changed 10 months ago by cypherpunks

And this TRAC system sometimes ask google captcha(older one, not current "Im not a robot" one).

Please consider switching it to [1], or make one and host it on this website(no 3P).

[1] https://coinhive.com/#captcha

comment:2 Changed 10 months ago by Dbryrtfbcbhgf

Status: newneeds_information

I tested on https://www.patreon.com/ running TorBrowser using the high security setting and I can get past the Captcha fine. Try closing TorBrowser, deleting the TorBrowser-data folder and try to reproduce the bug.

Last edited 10 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:3 Changed 10 months ago by Dbryrtfbcbhgf

Component: Webpages/BlogApplications/Tor Browser
Priority: Very HighMedium

comment:4 Changed 10 months ago by cypherpunks

Component: Applications/Tor BrowserCore Tor
Priority: MediumVery High

Test Google Captcha API via all Tor exits. You will see many exits are banned to reach.

#OONI

comment:5 in reply to:  4 Changed 10 months ago by Dbryrtfbcbhgf

Replying to cypherpunks:

Test Google Captcha API via all Tor exits. You will see many exits are banned to reach.

#OONI

I just tested it on another site and it works fine, please link the sites that are effected and the exit nodes that are effected, the exit node I tried worked with no problems, so it does not effect all exits.
I tested it again and keep getting the same results, it works every time.
Try closing TorBrowser, deleting the TorBrowser-data folder and try to reproduce the bug.
I am getting some "Try again latter errors", it may be a temporary issue for some of the exit IP's, when I go back to the main page of the search engine and research a term, I get the captcha and I'm able to use the search engine after I enter the correct infomation.

Last edited 10 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:6 Changed 10 months ago by Dbryrtfbcbhgf

Component: Core TorApplications/Tor Browser
Priority: Very HighMedium

comment:7 in reply to:  1 Changed 10 months ago by cypherpunks

Replying to cypherpunks:

And this TRAC system sometimes ask google captcha(older one, not current "Im not a robot" one).

Please consider switching it to [1], or make one and host it on this website(no 3P).

[1] https://coinhive.com/#captcha

No, it takes me +30min and it's still not finished.

comment:8 Changed 10 months ago by tokotoko

Cc: fdsfgs@… added

comment:9 Changed 10 months ago by cypherpunks

Resolution: worksforme
Status: needs_informationclosed

Haven't seen this for a while now, so closing until it appears again.

comment:10 Changed 10 months ago by tokotoko

I got this on etsy.com right now, it's not 50/50 lottery.

comment:11 Changed 10 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

Reopening then.

comment:12 in reply to:  10 ; Changed 10 months ago by tokotoko

Replying to tokotoko:

I got this on etsy.com right now, it's not 50/50 lottery.

it's 50/50 lottery*

comment:13 in reply to:  12 ; Changed 10 months ago by cypherpunks

Replying to tokotoko:

Replying to tokotoko:

I got this on etsy.com right now, it's not 50/50 lottery.

it's 50/50 lottery*

This ticket is about the Google captcha failing and giving an error "Your computer or network may be sending automated queries...", are you really sure that it gave you that error (which is what this ticket is about)?

Changed 10 months ago by tokotoko

Attachment: 1.png added

this?

comment:14 in reply to:  13 Changed 10 months ago by tokotoko

Replying to cypherpunks:

Replying to tokotoko:

Replying to tokotoko:

I got this on etsy.com right now, it's not 50/50 lottery.

it's 50/50 lottery*

This ticket is about the Google captcha failing and giving an error "Your computer or network may be sending automated queries...", are you really sure that it gave you that error (which is what this ticket is about)?

I attached image with error with the same text from google recaptcha, so, yes, i am sure.

comment:15 Changed 10 months ago by cypherpunks

https://coinhive.com/#captcha

Fuck off spreading your shitty monero miner. Captcha mustn't require javascript.

comment:16 in reply to:  15 Changed 10 months ago by cypherpunks

Replying to cypherpunks:

https://coinhive.com/#captcha

off spreading your shitty monero miner. Captcha mustn't require javascript.

Calm down please, such proposals should be met with real arguments (e.g. it is extremely slow when JIT is disabled, it drains batteries, ...etc) and not insults.

Changed 10 months ago by tokotoko

Attachment: 02-11-2017_14:24:34.png added

vultr

comment:17 Changed 10 months ago by tokotoko

Still happens.

comment:18 Changed 10 months ago by gk

Component: Applications/Tor BrowserCommunity/Outreach

Nothing we can do from the browser side. Let's see whether the community (team) thinks doing a blog post/outreach/raising awareness is a thing they want to take on.

comment:19 Changed 9 months ago by cypherpunks

I just restart Tor service when this happens. But yeah... this thing still happening.

gk, you guys made a deal with Cloudflare this year. Do you think you can talk with
Recaptcha.net devs about this?

Nowadays many corporate site AND cloudflared site use Google Recaptcha. This must get
more attention

comment:20 Changed 9 months ago by cypherpunks

Priority: MediumVery High
Severity: NormalCritical

It's happening pretty much in most of the tries when Google captcha is served in all websites (except those Cloudflare captcha pages)

comment:21 Changed 9 months ago by cypherpunks

https://discordapp.com/invite/XXXXXXXXX (X=ID)

Can't complete the process because of this!

"Why, hello there. beep boop. boop beep?"
[ ] I'm not a robot

Clicking on the checkbox instantly greet me with

Try again later
Your computer BLAH BLAH BLAH

Seriously though, why Tor devs don't write a blog now? You did this when you hit by a cloudflare.

comment:22 Changed 9 months ago by cypherpunks

Can someone test captcha API through all exit nodes to determine how many % are affected?
Seems to me 99% of my browsing failed to pass that stupid google captcha.

I hate Google. Deadly serious!!

Changed 9 months ago by tokotoko

Attachment: e-hentai_recaptcha.png added

comment:23 Changed 9 months ago by tokotoko

This happens more and more often.

comment:24 in reply to:  description Changed 9 months ago by indigotime

This problem happens nearly everywhere...

It looks like implementation of anonymizer/VPN prohibition laws.

comment:25 Changed 9 months ago by cypherpunks

Priority: Very HighImmediate

Had to use "New Tor Circuit for this Site" 4 times to finally get it to work ... This is starting to be annoying and silly.

comment:26 Changed 9 months ago by indigotime

"New Tor Circuit for this Site" keeps current cookies, including cloudflare/recaptcha cookies. Cloudflare and Google can use cookies to detect (and blacklist) new Tor exit nodes.

comment:27 Changed 9 months ago by cypherpunks

Still happening here. Tested yesterday and today. Can't register on the forum(not here) because of google captcha. Am so frustrating now.

comment:28 Changed 9 months ago by cypherpunks

Component: Community/OutreachCommunity/Tor Support
Parent ID: #24351
  • See also #24351
  • For now, use PAID VPN if you seriously need to read cloudflare-walled website. (read torrentfreak's VPN review and research VPN provider's court case to determine no-log VPN for your own)
  • Join #24351 to end Cloudflare! That MiTM access point must be destroyed for open internet.

comment:29 Changed 9 months ago by cypherpunks

Component: Community/Tor SupportApplications/Tor Browser

A lot of cries and no constructive action again.
Recaptcha fails when

09:00:15.693 NetworkError: Failed to load worker script at https://www.gstatic.com/recaptcha/api2/r20171115120512/recaptcha__en.js (nsresult = 0x805e0006) 1 webworker.js:1

from https://www.google.com/recaptcha/api2/webworker.js?hl=en&v=r20171115120512

If you are testing with https://news.ycombinator.com/item?id=11022315, you can also hit

Firefox can’t find the file at https://news.ycombinator.com/item?id=11022315.

or

Web server is returning an unknown error

There is an unknown connection issue between Cloudflare and the origin web server. As a result, the web page can not be displayed.

    Ray ID: 3c23166f2b7f2d8f
    Your IP address: 192.36.27.6
    Error reference number: 520
    Cloudflare Location: Berlin

Therefore, server should have a reliable connection to test recaptcha, for example, https://www.etsy.com/join?ref=hdr&from_page=https%3A%2F%2Fwww.etsy.com%2F

comment:30 in reply to:  29 Changed 9 months ago by cypherpunks

Component: Applications/Tor BrowserCommunity/Tor Support

Replying to cypherpunks:

A lot of cries and no constructive action again.

That's because the problem stems from Google, and there's nothing TB-team can do other than speak up.

comment:31 Changed 9 months ago by cypherpunks

Severity: CriticalBlocker

comment:32 Changed 8 months ago by cypherpunks

Can anyone from the Tor Project at least try to contact some Google folks to try to work on this issue? I can no longer create a Gitlab account because the Google Captcha always fails no matter how much I keep trying different circuits, so this totally destroys my dev browsing experience.

comment:33 Changed 8 months ago by cypherpunks

I still can't login!!
This will result in noob tor broser given up and move to normal, censored, monitored network.

Tor devs please respond, over!

comment:34 Changed 8 months ago by cypherpunks

https://support.google.com/recaptcha/answer/6081888?hl=en

We're sorry, but your computer or network may be sending automated queries. To protect our users, we can't process your request right now.

equals:

We're sorry, but we can't track you if you continue to use Tor network.
To protect our good information-domestic sheep and cows, aka "users",
we refuse to serve anonymous users. Take off you clothes now or walk away.

comment:35 Changed 8 months ago by cypherpunks

The blocking might be related to your use of a Virtual Private Network (VPN) browser plugin or program. You might try uninstalling the VPN from your computer or network and see if that makes a difference.

Some VPNs send traffic that violates the law or websites' terms of service. If you're an Internet Service Provider (ISP), explain to your users why they should uninstall these VPNs.

https://support.google.com/websearch/answer/86640

🤦 🤦 🤦 🤦 🤦 🤦 🤦 🤦 🤦

comment:36 Changed 8 months ago by cypherpunks

Wow can't even create an account on BitBucket now https://bitbucket.org/account/signup/

comment:37 Changed 8 months ago by cypherpunks

Parent ID: #24351

comment:38 Changed 8 months ago by cypherpunks

Summary: Cloudflare and Google Captcha failed 100%Google Captcha fails 100%

It's not Cloudflare that's the problem here, it's Google.

comment:39 in reply to:  38 ; Changed 8 months ago by cypherpunks

Keywords: noscript added
Summary: Google Captcha fails 100%Cloudflare and Google Captcha fails 99%

Replying to cypherpunks:

It's not Cloudflare that's the problem here, it's Google.

Are you sure?
It's less than 2 seconds for you to press the captcha, it seems:

Date Sun, 10 Dec 2017 15:44:36 GMT
Expires Sun, 10 Dec 2017 15:44:38 GMT
Server cloudflare-nginx

Also

NetworkError: Failed to load worker script at https://www.gstatic.com/recaptcha/api2/r20171115120512/recaptcha__en.js (nsresult = 0x805e0006) webworker.js:1

on higher security levels. See https://forums.informaction.com/viewtopic.php?f=7&t=24272
But all captchas are solvable (with New Identity).

Oh, and #19910, of course, but who cares?No image "[[Image(" attached to Ticket #23840)]]

Last edited 8 months ago by cypherpunks (previous) (diff)

comment:40 in reply to:  39 Changed 8 months ago by cypherpunks

Summary: Cloudflare and Google Captcha fails 99%Google's reCAPTCHA fails 99%

Replying to cypherpunks:

Replying to cypherpunks:

It's not Cloudflare that's the problem here, it's Google.

Are you sure?

Yes, since it happens everywhere where a Google reCAPTCHA is found and not just on Cloudflare's Captcha challenge pages.

comment:41 Changed 8 months ago by cypherpunks

Cloudflare is using Google's reCaptcha API.
So "Google's reCAPTCHA fails 99%" is the correct title.

Er...

Tor developers! Say something already!!

comment:42 Changed 8 months ago by cypherpunks

Parent ID: #18361

comment:43 Changed 8 months ago by cypherpunks

Resolution: not a bug
Status: reopenedclosed

comment:44 Changed 8 months ago by cypherpunks

Resolution: not a bug
Status: closedreopened

comment:45 Changed 8 months ago by cypherpunks

Resolution: worksforme
Status: reopenedclosed

comment:46 Changed 8 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened
Summary: Google's reCAPTCHA fails 99%Google's reCAPTCHA fails 100000000000000000000000000000000%

comment:47 Changed 8 months ago by cypherpunks

Summary: Google's reCAPTCHA fails 100000000000000000000000000000000%Google's reCAPTCHA fails 99%

Please stop the vandalism.

comment:48 Changed 8 months ago by cloudflarezoey

Parent ID: #18361

comment:49 Changed 7 months ago by cypherpunks

The geniuses at Google got a patent for this: "Blocking via an unsolvable CAPTCHA" https://www.google.com/patents/US9407661

🤦 🤦 🤦 🤦 🤦 🤦 🤦 🤦 🤦

comment:50 Changed 7 months ago by cypherpunks

Parent ID: #18361

comment:51 Changed 7 months ago by cypherpunks

Damn... Happening again. Google ban 100% Tor exits.

Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page

comment:52 Changed 7 months ago by cypherpunks

Fuck you Google and Cloudflare. I mean it.

comment:53 Changed 7 months ago by cypherpunks

Keywords: cloudflare google captcha added
Summary: Google's reCAPTCHA fails 99%Google's reCAPTCHA fails 100%

Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page
Try again later
Your computer or network may be sending automated queries. To protect our users, we can't process your request right now. For more details visit our help page

They clearly marking all exits automatically.
Why Tor didn't ask Google about this?!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

comment:54 Changed 7 months ago by cypherpunks

Summary: Google's reCAPTCHA fails 100%Google's reCAPTCHA fails 100% #HumanIsCategorizedAsARobot #FuckGoogle

comment:55 Changed 7 months ago by cypherpunks

Summary: Google's reCAPTCHA fails 100% #HumanIsCategorizedAsARobot #FuckGoogleGoogle's reCAPTCHA fails 100%

Please stop with your clownish vandal edits.

comment:56 Changed 6 months ago by cypherpunks

not fixed

comment:57 Changed 6 months ago by cypherpunks

Given how common these CAPTCHAs are, it should be quite easy to verify if Google/ReCAPTCHA are in fact automatically blocking Tor exits, and call them out publicly on their behavior should that be the case. Site owners should be free to decide whether or not to block people coming from a Tor exit from accessing a service (and the Tor project supplies tools to make this technically easy); this should never occur simply as a side-effect of a third-party service that's supposed to tell humans apart from robots/automated clients.

Last edited 6 months ago by cypherpunks (previous) (diff)

comment:58 Changed 5 months ago by cypherpunks

This issue has now Mike Perry level attention, that means we did some good progress :) https://lists.torproject.org/pipermail/tor-project/2018-March/001691.html

comment:59 in reply to:  58 ; Changed 5 months ago by cypherpunks

Replying to cypherpunks:
Where does Mike PERRY care at, please.

comment:60 in reply to:  59 Changed 5 months ago by cypherpunks

Replying to cypherpunks:

Where does Mike PERRY care at, please.

He did give an update,

2) Wrote a draft to send to a Google DoS engineer I know about recaptcha
and privacy pass, ran it by gk. Will send today.
https://lists.torproject.org/pipermail/tor-project/2018-March/001702.html

comment:61 Changed 4 months ago by cypherpunks

Mike:
1) On the thread with Google about ReCaptcha: To be honest, I think that
reaching out to them like this is a waste of time. I should have
objected to the idea earlier. Public pressure about exactly how bad this
situation is will be the only thing that will move the needle in terms
of them devoting resources to the problem. For pete's sake.. This is a
company that is basically the primary/only gateway to much of the
Internet, and it has decided that certain IP addresses *do not deserve
access to that Internet*. Full stop. This is not a problem that gets
solved by having our devs talk to their devs to "nerd harder". This
should be a PR bloodbath..  We should have made it one months ago.

https://lists.torproject.org/pipermail/tor-project/2018-April/001738.html

(BtW if you didn't know: chrome sucks, chromium sucks, v8 js engine sucks, chromum's networking stack sucks, recapatcha sucks, chromebooks suck, google sucks)

comment:62 Changed 4 months ago by soicey

So in conclusion, there is no solution and we are screwed?

comment:63 in reply to:  62 Changed 4 months ago by cypherpunks

Replying to soicey:

So in conclusion, there is no solution and we are screwed?

This is what you get when you allow a monopoly to take over other areas (Loolle Fonts, Loolle js CDN, Loolle Groups, Loolle Books, Loolle Captchas, Loolle Browser, ...). Support Mozilla and the Tor Project and stop telling your friends how secure Loolle Browser is and how the TB team should've went with Loolle Browser.

It took PR uncomfortable Cloudflare 2 and something years to finally loosen the apartheid wall around Tor Browser users and to switch to gate keeping mode only for some. I wonder whether PR comfortable Loolle will ever care. Maybe they'll remove *.torproject.org domains in their search engine someday.

comment:64 Changed 3 months ago by cypherpunks

Resolution: wontfix
Status: reopenedclosed

Become a bot to solve the captcha automatically

comment:65 Changed 3 months ago by cypherpunks

Resolution: wontfix
Status: closedreopened

This still happens, cypherpunks above, why are you ruining the party?

comment:66 Changed 3 months ago by indigotime

NetworkError: Failed to load worker script at https://www.gstatic.com/recaptcha/api2/v1526884278587/recaptcha__en.js (nsresult = 0x805e0006) 1 webworker.js:1

recaptchaen.js should be delivered locally to prevent this error.

comment:67 Changed 3 months ago by cypherpunks

Resolution: invalid
Status: reopenedclosed

comment:68 Changed 3 months ago by cypherpunks

Resolution: invalid
Status: closedreopened

Still not fixed, please don't vandalize.

comment:69 Changed 3 months ago by cypherpunks

Great party, I'm in.

https://en.wikipedia.org/wiki/ReCAPTCHA

Houck also mentioned security defenses in the system, including a high security lock out if an invalid response is given 32 times in a row.

comment:70 Changed 3 months ago by cypherpunks

Resolution: fixed
Status: reopenedclosed

Provide proof or else.

comment:71 Changed 2 months ago by cypherpunks

I rarely saw any recaptcha fail lately, maybe it's fixed for good for the time being . . .

Note: See TracTickets for help on using tickets.