Opened 9 years ago

Closed 8 years ago

#2386 closed enhancement (fixed)

Start shipping TBBs containing Tor 0.2.2.x

Reported by: rransom Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Some Tor Browser Bundle users need to configure their Tor client to connect to Tor through a SOCKS proxy, but Tor 0.2.1.x does not have SOCKS client support. We should provide TBBs containing Tor 0.2.2.x for those users.

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by erinn

Status: newaccepted

I agree, and I plan to start making Windows TBBs with 0.2.2.x as soon as 0.2.2.x becomes stable. Hopefully that is soon. (I don't intend to maintain two versions of Windows TBBs until I have much better build infrastructure set up.)

comment:2 Changed 8 years ago by rransom

Priority: criticalmajor

We now have alpha bundles containing Tor 0.2.2.x for Linux and (maybe?) MacOS, but they're hidden away on archive.tpo.

Decreasing the priority, though, because users in Iran no longer need to connect to Tor through SOCKS proxies at the moment.

comment:3 Changed 8 years ago by erinn

Resolution: fixed
Status: acceptedclosed

We have bundles available for Windows users with Tor 0.2.2.x, and since it's about to go stable they will soon be the default. Closing.

Note: See TracTickets for help on using tickets.