Opened 2 years ago

Closed 2 years ago

#23867 closed defect (duplicate)

Can not build Tor Browser Bundle json: cannot unmarshal object into Go value of type []string

Reported by: kv1835946 Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello.

Can not build Tor Browser Bundle. Trying different OS. Strictly following guide. Is using clean OS.
Latest tried Ubuntu 17.04 64-bit.

Here's last lines:

--2017-10-10 07:22:49--  http://cdimage.ubuntu.com/ubuntu-base/releases/17.04/release/ubuntu-base-17.04-base-amd64.tar.gz
Resolving cdimage.ubuntu.com (cdimage.ubuntu.com)... 91.189.88.165
Connecting to cdimage.ubuntu.com (cdimage.ubuntu.com)|91.189.88.165|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 36461782 (35M) [application/x-gzip]
Saving to: '/compile/tor-browser-build/out/debootstrap-image/container-image_ubuntu-base-17.04-base-amd64.tar.gz'

/compile/tor-browser-build/out/debootstrap-image/container- 100%[========================================================================================================================================>]  34.77M  11.6MB/s    in 3.0s

2017-10-10 07:22:52 (11.6 MB/s) - '/compile/tor-browser-build/out/debootstrap-image/container-image_ubuntu-base-17.04-base-amd64.tar.gz' saved [36461782/36461782]

Using file /compile/tor-browser-build/out/debootstrap-image/container-image_ubuntu-base-17.04-base-amd64.tar.gz
Error: Error starting remote:

json: cannot unmarshal object into Go value of type []string

Makefile:75: recipe for target 'testbuild-windows-i686' failed
make: *** [testbuild-windows-i686] Error 1

Any idea please?

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by boklm

This looks like a duplicate of #23812.

Could you check if the proposed patch in #23812 is fixing the issue?

https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_23812_v2&id=0b698f41ac88ef08b33d070a576c9f5649238af6

comment:2 Changed 2 years ago by gk

Keywords: tbb-rbm added
Resolution: duplicate
Status: newclosed

Marking this as duplicate of #23812. Please reopen if this is still an issue.

Note: See TracTickets for help on using tickets.