Opened 2 years ago

Closed 11 months ago

#23889 closed defect (wontfix)

Tor launcher throwing that it can't find localization

Reported by: arlolra Owned by: sukhbir
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: sukhbir, dcf Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Some strings are missing. Starting the app with LANG=C avoids the issue.

Child Tickets

Attachments (1)

tormessenger-error.png (13.8 KB) - added by dcf 2 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 2 years ago by arlolra

Owner: set to sukhbir
Status: newassigned

Changed 2 years ago by dcf

Attachment: tormessenger-error.png added

comment:2 Changed 2 years ago by dcf


I got the error with Tor Messenger 0.5.0b1 on Debian 9.1 (stretch) x86_64. When I installed the system, I had chosen the Polish language option. I ran the program like this:

$ ./start-tor-messenger.desktop

Note that, after the error appears, Tor Launcher will go ahead and bootstrap invisibly and the Tor Messenger UI will appear eventually. After that, the error will no longer appear, because Tor Launcher won't show the configuration dialog by default (it goes straight to the bootstrap progress bar). To force the error to happen again, you can do:

$ TOR_FORCE_NET_CONFIG=1 ./start-tor-messenger.desktop

I am not able to reproduce the error on a Debian buster x86_64 system, using

$ LANG=pl TOR_FORCE_NET_CONFIG=1 ./start-tor-messenger.desktop

The Tor Launcher interface just appears in Polish. So it could be some other setting that got set when I made the language selection at system install time.

comment:3 Changed 2 years ago by arlolra

Similar to #20231

comment:4 Changed 11 months ago by traumschule

Resolution: wontfix
Status: assignedclosed

<+sukhe> hello. yes, I think it's fine to close the tickets. thanks for doing what we should done earlier :)

Note: See TracTickets for help on using tickets.