Opened 13 months ago

Closed 4 weeks ago

#23925 closed task (fixed)

2018 Tor Browser donation banner

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fundraising, ux-team, TorBrowserTeam201810R
Cc: sstevenson@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by arthuredelstein)

For Year End 2018 we want a fundraising banner in Tor Browser with a donation button. Let's make the activation time the same for all time zones, so we have a simultaneous launch. Or better yet, we can just launch it immediately on update. The banner design is in progress.

Child Tickets

TicketStatusOwnerSummaryComponent
#23995closedtbb-teamAdd a permanent way to opt out of Tor Browser advertising as a pref.Applications/Tor Browser
#24172closedtbb-teamdonation banner clobbers tor browser version stringApplications/Tor Browser
#27959closedtbb-team2018 Tor Browser donation banner textApplications/Tor Browser

Change History (12)

comment:1 Changed 12 months ago by gk

Type: defecttask

comment:2 Changed 3 months ago by arthuredelstein

Cc: sstevenson@… added
Description: modified (diff)
Keywords: tbb-fundraising ux-team added
Summary: 2018 Tor Browser banner2018 Tor Browser donation banner

comment:3 Changed 4 weeks ago by arthuredelstein

Keywords: TorBrowserTeam201810R added
Status: newneeds_review

comment:4 Changed 4 weeks ago by gk

Status: needs_reviewneeds_information

So, we are trying to get information about user behavior with respect to our banner by sending them to a different URL depending on text and button text (the latter only for en locales) shown. This happens without the user even being aware of that given that the button does not indicate where they are going to nor the URL bar where the finally land after redirects. I think I have some concerns here:

1) What happens with the data we collect that way? And who has access to it?
2) I think whatever the answer to 1) is we should be transparent about it and inform the user somewhere.
3) I think the user should at least be able to be aware about what is happening *before* they click on the button that leads them to the donation page. Maybe showing the URL they are about to go to would be a good step in that direction.

comment:5 Changed 4 weeks ago by sstevenson

The URLs are following the model used in last year's YE campaign to see which banners generated the most traffic to the donate page.

1) Metrics has access to the data and will report the number of times each URL was accessed.

I don't know how to answer the other questions, but do whatever works best.

comment:6 in reply to:  5 Changed 4 weeks ago by gk

Replying to sstevenson:

The URLs are following the model used in last year's YE campaign to see which banners generated the most traffic to the donate page.

I don't think that's the case for the *browser* part. We had

https://www.torproject.org/donate/donate-pdr-tbb + short locale for the 2017 button link
https://www.torproject.org/donate/donate-tbb + short locale for the 2016 button link and
https://www.torproject.org/donate/donate-tbb for the 2015 button link.

1) Metrics has access to the data and will report the number of times each URL was accessed.

Okay, sounds good.

comment:7 Changed 4 weeks ago by gk

So, to get an understanding what the design was supposed to be: the idea is to understand
a) which text gives us the most money and
b) whether the two button texts for en builds have an influence on how much money we get?

Or was the idea to get different information and the patch does not match the spec? :)

comment:8 Changed 4 weeks ago by sstevenson

Right, last year just tracked the locale. The idea is to get a sense if some text generates more clicks than others. We can't tie that to income because we won't know if the person completed a donation and the amount. The text we landed on for this round of banners isn't too distinct so won't give us that much information. However, for the next update, we'd ideally like to try some different types of messages and see how they appeal to the audience.

comment:9 in reply to:  4 ; Changed 4 weeks ago by gk

Keywords: TorBrowserTeam201810 added; TorBrowserTeam201810R removed
Status: needs_informationneeds_revision

Replying to gk:

3) I think the user should at least be able to be aware about what is happening *before* they click on the button that leads them to the donation page. Maybe showing the URL they are about to go to would be a good step in that direction.

We did so at least last year and I think we should show the URL, which a user is about to go to, again if they are hovering over the button.

comment:10 in reply to:  9 Changed 4 weeks ago by arthuredelstein

Status: needs_revisionneeds_review

Replying to gk:

Replying to gk:

3) I think the user should at least be able to be aware about what is happening *before* they click on the button that leads them to the donation page. Maybe showing the URL they are about to go to would be a good step in that direction.

We did so at least last year and I think we should show the URL, which a user is about to go to, again if they are hovering over the button.

Good idea and thanks for the review. I should note that I am not including the locale in the URL in this banner, because it occurred to me that we are in general promising users not to reveal their locale if they choose to spoof navigator.language. However, the donate page will still show the right locale if the user is not spoofing. So the only thing our URL is revealing is which text the user clicked on, which I think doesn't reveal much about individual users.

Here's my revised patch:

https://github.com/arthuredelstein/torbutton/commit/23925+1

This version shows the URL in the status bar when the user hovers over the button (because the button is now an <a> element). In this revision I have also added cyan highlighting over part of Line 2 as designed by Antonela in https://marvelapp.com/a131e34/screen/48876402.

Here are a couple of example screenshots:

comment:11 Changed 4 weeks ago by arthuredelstein

Keywords: TorBrowserTeam201810R added; TorBrowserTeam201810 removed

comment:12 Changed 4 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks, looks good. And +1 to the locale not included in the URL. Commit 4c9e8dc0f8a0d45f6955801a24a1d45a98cccdf0 on master and commit 7fcfd07a4a031e86cb2c9000993319c62ae9c0e2 on maint-2.0 have the fix.

Note: See TracTickets for help on using tickets.