#23956 closed defect (duplicate)

Sandbox unusable after update (Debian)

Reported by: helpful_guy Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version: Tor: 0.3.1.7
Severity: Major Keywords: prctl
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After the update to 7.0.7, I get:

2017/10/23 10:09:04 firefox: Sandbox: prctl(PR_SET_NO_NEW_PRIVS) failed: Function not implemented

The result is no site can be visited, and all new tabs crash with the firefox "Gah" message. The fuller context is below.

On load the tor log messages are normal, but firefox says:

2017/10/23 10:09:03 firefox: 1508778543200        addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232}        WARN        Loading extension '{73a6fe31-595d-460b-a920-fcc0f8843232}': Reading manifest: Error processing permissions.1: Unknown permission "privacy"
2017/10/23 10:09:03 firefox: 1508778543200        addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232}        WARN        Loading extension '{73a6fe31-595d-460b-a920-fcc0f8843232}': Reading manifest: Error processing permissions.4: Unknown permission "unlimitedStorage"
2017/10/23 10:09:03 firefox: 1508778543300        addons.webextension.https-everywhere-eff@eff.org        WARN        Loading extension 'https-everywhere-eff@eff.org': Reading manifest: Error processing devtools_page: An unexpected property was found in the WebExtension manifest.
2017/10/23 10:09:03 firefox: 1508778543400        addons.webextension.https-everywhere-eff@eff.org        WARN        Please specify whether you want browser_style or not in your browser_action options.

Firefox does open, but any attempt to visit a URL produces this set of messages:

2017/10/23 10:09:04 firefox: Sandbox: prctl(PR_SET_NO_NEW_PRIVS) failed: Function not implemented
2017/10/23 10:09:04 firefox: [Parent 3] WARNING: pipe error (59): Connection reset by peer: file /home/debian/build/tor-browser/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
2017/10/23 10:09:04 firefox: [Parent 3] WARNING: pipe error (57): Connection reset by peer: file /home/debian/build/tor-browser/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
2017/10/23 10:09:04 firefox: ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0086,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

Child Tickets

Change History (2)

comment:1 Changed 18 months ago by cypherpunks

Summary: Tor unusable after update (Debian)Sandbox unusable after update (Debian)

comment:2 Changed 18 months ago by yawning

Resolution: duplicate
Status: newclosed

Duplicate of #23692

Note: See TracTickets for help on using tickets.