Opened 8 months ago

Last modified 9 days ago

#23968 reopened defect

NoScript icon jumps to the right after update

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: noscript
Cc: ma1, catalyst Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We had this issue as part of #23724 but it still seems to be not fixed. After the update to NoScript 5.1.3 (from 5.1.2) the icon jumps to the right and the following error is visible in the browser console

CustomizableUI: Widget 'noscript-tbb' not found, unable to move CustomizableUI.jsm:1149

This got reported on our blog (https://blog.torproject.org/comment/272025#comment-272025).

Child Tickets

Change History (11)

comment:1 Changed 8 months ago by ma1

It should be fixed in 5.1.4rc1 from https://noscript.net/getit#devel, please confirm.

comment:2 in reply to:  1 Changed 8 months ago by gk

Replying to ma1:

It should be fixed in 5.1.4rc1 from https://noscript.net/getit#devel, please confirm.

Updating from 5.1.2 -> 5.1.3 let's the icon jump to the right. Updating from 5.1.3rc3 to 5.1.4rc1 does not do this in a comparable environment. Thus, seems to work for me, thanks.

comment:3 Changed 8 months ago by gk

Resolution: fixed
Status: newclosed

This got included into 5.1.4, thanks.

comment:4 Changed 7 months ago by catalyst

Cc: catalyst added
Resolution: fixed
Status: closedreopened

I just upgraded from 7.5a7 to 7.5a8 on Linux and the NoScript button jumped to the right after the automatic post-update restart.

comment:5 Changed 7 months ago by cypherpunks

I can confirm NoScript auto update to version 5.1.7 caused the icon to jump to the right in Tor Browser 7.0.10

comment:6 Changed 7 months ago by cypherpunks

Didn't happen for me after being lucky enough to upgrade from 5.1.6 to 5.1.7

comment:7 Changed 7 months ago by gk

So, I tried a bit but am not able to reproduce the issue. If anybody has steps to do so (e.g. starting with a clean Tor Browser 7.0.10 or 7.5a8) let us know.

comment:8 Changed 7 months ago by cypherpunks

I wrote about NoScript icon jumping in 7.0.10. I couldn't reproduce on a clean extract. I should have checked that before posting, I'm sorry about that. The extract that I used had extra add-ons installed, umatrix and ublock origin.

comment:9 Changed 5 months ago by cypherpunks

5.1.8.3 -> 5.1.8.4 without e10s.

comment:10 in reply to:  9 ; Changed 9 days ago by cypherpunks

Replying to cypherpunks:

5.1.8.3 -> 5.1.8.4 without e10s.

Same to 5.1.8.6. No improvement for over half a year, is NoScript dead?

comment:11 in reply to:  10 Changed 9 days ago by cypherpunks

Replying to cypherpunks:

Same to 5.1.8.6. No improvement for over half a year, is NoScript dead?

This isn't an issue with NoScript, it happens even in the FF60-esr based Tor Browser nightly build with both NoScript WebExtension and HTTPS Everywhere.

Note: See TracTickets for help on using tickets.