Opened 23 months ago

Closed 13 months ago

Last modified 13 months ago

#24024 closed defect (not a bug)

Potentially misleading illustrations suggest that Tor doesn't stick to a single guard node in the overview page

Reported by: cypherpunks Owned by: ggus
Priority: Medium Milestone: website redesign
Component: Webpages/Website Version:
Severity: Normal Keywords: bridge
Cc: arma Actual Points:
Parent ID: #25218 Points:
Reviewer: Sponsor:

Description

https://www.torproject.org/about/overview.html.en

The entry node in the third image is different from the one in the second image

Child Tickets

Change History (9)

comment:1 Changed 18 months ago by hiro

Milestone: website redesign

comment:2 Changed 13 months ago by traumschule

Keywords: bridge added
Owner: set to ggus
Status: newassigned

do think it's easy to fix this? https://www.torproject.org/images/htw3.svg

comment:3 Changed 13 months ago by teor

But Tor doesn't stick to a single guard node right now, and we have a proposal to make it use two guards in a balanced way:
https://gitweb.torproject.org/torspec.git/tree/proposals/291-two-guard-nodes.txt

comment:4 Changed 13 months ago by traumschule

thanks for the link, we should prepare an image for it as well then. currently the entry is stable for up to three months according to https://support.torproject.org/tbb/tbb-2/
the text should explain the current system (with above link) and the upcoming change to prepare users.

comment:5 in reply to:  4 Changed 13 months ago by teor

Replying to traumschule:

thanks for the link, we should prepare an image for it as well then. currently the entry is stable for up to three months according to https://support.torproject.org/tbb/tbb-2/
the text should explain the current system (with above link) and the upcoming change to prepare users.

There is no upcoming user-visible change.

Tor uses 2 guards for circuits now. It will use 2 guards for circuits in future, but in a more balanced way.

comment:6 Changed 13 months ago by traumschule

I see, does this mean the current images in the overview are correct and the FAQ answer should be updated, because the first address cannot be always the same, or can we just close this?

comment:7 Changed 13 months ago by teor

I don't know which FAQ your are talking about, please post a link to the answer.

comment:8 Changed 13 months ago by teor

Resolution: not a bug
Status: assignedclosed

If you're talking about this FAQ:
https://support.torproject.org/tbb/tbb-2/

Then I think it's fine for now. Trying to explain that the guard is almost always the same is hard.

When we implement proposal 291, we can change the answer to say "two guards".

comment:9 Changed 13 months ago by traumschule

Parent ID: #25218

yes, meant this one. Thanks!
(Setting parent to keep this as a reference when working on the bridges page later)

Note: See TracTickets for help on using tickets.