#24034 closed defect (duplicate)

exitaddresses, and bulkexitlist, (and check?), don't know about IPv6

Reported by: arma Owned by:
Priority: Medium Milestone:
Component: Core Tor/TorDNSEL Version:
Severity: Normal Keywords:
Cc: arlolra, karsten Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

https://check.torproject.org/cgi-bin/TorBulkExitList.py?ip=69.55.226.35&port=80
gives me a pile of ipv4 addresses. I think it parses
https://check.torproject.org/exit-addresses
plus maybe descriptors or consensuses to get exit policies.

But tordnsel was written back when IPv6 was not a thing. So that means every step of our pathway is missing the concept of IPv6.

I guess the most urgent part to fix, which ties into metrics, is that we aren't collecting the ipv6 exit addresses of relays, which means we won't be able to look back in time and answer questions that have to do with ipv6 connections out of Tor.

Child Tickets

Change History (4)

comment:1 Changed 19 months ago by arma

Cc: arlolra karsten added

Adding Arlo and Karsten as two hopefully interested parties.

comment:2 Changed 19 months ago by arma

(bug reported by a user who was trying to handle abuse by a Tor user to their website, and found that ipv6 connections and addresses were totally missing from our metrics infrastructure)

comment:3 Changed 19 months ago by arlolra

Dupe of #16947

Also, see https://www.fredericjacobs.com/blog/2016/08/18/torcheck-ipv6/ and #19940

And an ml thread Mike wrote called "Ownership for check.torproject.org?"

comment:4 Changed 19 months ago by arma

Resolution: duplicate
Status: newclosed

Well shoot. You're right. Thanks.

Karsten, should this get on the metrics roadmap somehow? :)

Note: See TracTickets for help on using tickets.