Opened 9 years ago

Closed 9 years ago

#2406 closed defect (fixed)

OS X bundles can't launch Tor (libevent linked dynamically)

Reported by: Sebastian Owned by: erinn
Priority: Very High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Neither TBB nor the Vidalia bundles contain a Tor that has libevent linked statically, so launching Tor will fail without any recognizable error message in Vidalia.

Launching the tor by hand gives:

dyld: Library not loaded: /usr/local/lib/libevent-1.4.2.dylib
  Referenced from: /Users/killerchicken/Downloads/TorBrowser_en-US.app/Contents/MacOS/./tor
  Reason: image not found
Trace/BPT trap

So far I have seen only 10.6 users report this issue, but I am almost sure that other users are affected as well.

I'll try to hunt down our installation instructions to see where they can be improved. I'm also not sure why this did not occur before today, maybe something changed in the build setup (maybe libevent was compiled with --disable-shared before or something, but that's anyone's guess).

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by Sebastian

TBB fix in branch bug2406 in my torbrowser repository

comment:2 Changed 9 years ago by Sebastian

Status: newneeds_review

In vidalia, the instructions in pkg/osx/build-bundle.txt step 10 need to be updated as well. They need to include --enable-static-openssl --enable-static-zlib --enable-static-libevent along with --with-XXX-dir options for each for the path.

comment:3 Changed 9 years ago by Sebastian

Resolution: fixed
Status: needs_reviewclosed

I believe this has been fixed by helix. Yay!

Note: See TracTickets for help on using tickets.