Opened 2 years ago

Closed 2 years ago

#24096 closed defect (not a bug)

cURL error 7: Can't complete SOCKS5 connection to 0.0.0.0:0. (6)

Reported by: ahmad.saeed Owned by: phoul
Priority: Immediate Milestone:
Component: Community/Tor Support Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using TOR with curl on ubuntu and after some specific number of requests it gives an error
cURL error 7: Can't complete SOCKS5 connection to 0.0.0.0:0. (6) (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
Actually I'm scrapping websites using PHP cURL with TOR as a background system service. It goes well until a limited/specific no of requests before throwing this error where curl is not able to connect TOR proxy through socket

Child Tickets

Change History (1)

comment:1 Changed 2 years ago by dgoulet

Resolution: not a bug
Status: newclosed

We'll need tor logs to be able to assist but right off the bat, seeing 0.0.0.0:0 should tell you that curl is trying to reach something not reachable.

Error 7 should be "can't connect to proxy" but the address should be 127.0.0.1:9050 by default, the Tor SOCKS port.

Note: See TracTickets for help on using tickets.