#24111 closed defect (wontfix)

firefox: Fatal IO error 11 under load

Reported by: yawning Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Normal Keywords:
Cc: arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

2017/10/24 04:34:29 firefox: firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
2017/10/24 04:34:29 firefox:
2017/10/24 04:34:29 firefox: [Child 50] ###!!! ABORT: Aborting on channel error.: file /home/debian/build/tor-browser/ipc/glue/MessageChannel.cpp, line 2152
2017/10/24 04:34:29 firefox: [Child 50] ###!!! ABORT: Aborting on channel error.: file /home/debian/build/tor-browser/ipc/glue/MessageChannel.cpp, line 2152
2017/10/24 04:34:29 tor: Oct 24 08:34:29.000 [notice] Catching signal TERM, exiting cleanly.
2017/10/24 04:34:29 failed to accept control conn: accept unix /run/user/1000/sandboxed-tor-browser/control: use of closed network connection
2017/10/24 04:34:29 failed to accept SOCKS conn: accept unix /run/user/1000/sandboxed-tor-browser/socks: use of closed network connection

I assume the X11 surrogate falls behind when doing things that are extremely graphically intensive on anemic hardware or something, but that's just a hypothesis since I don't have reproduction instructions.

I'm not going to remove the surrogate since filtering extensions is a more reliable way to fix the MIT-SHM related crashes that hooking the X libraries never completely solved.

Child Tickets

Change History (5)

comment:1 Changed 21 months ago by cypherpunks

Perhaps ask on Freenode's #xorg or #xorg-dev, because surely there is a way to disable MIT-SHM without using an X11 proxy. If that's absolutely not possible, then the best solution may be to rewrite the proxy in a language which you can better optimize, like C or even ASM.

comment:2 Changed 21 months ago by arma

Confirmed.

This just happened to me when I had a slack window open in my Sandboxed Tor Browser.

Before, it happened pretty consistently after an hour or two if you leave Nickm's insidious paperclip game running in the background.

comment:3 Changed 21 months ago by arma

Summary: Firefox crashes under load(?)firefox: Fatal IO error 11 under load

comment:4 in reply to:  2 Changed 21 months ago by yawning

Replying to arma:

Confirmed.

This just happened to me when I had a slack window open in my Sandboxed Tor Browser.

I don't use slack. Hmm.

Before, it happened pretty consistently after an hour or two if you leave Nickm's insidious paperclip game running in the background.

That doesn't mean anything to me, maybe a URL? FWIW I've never seen this happen. All my Tor Browser crashes in recent memory have been of the form:

[349918.977738] Chrome_ChildThr[14777]: segfault at 0 ip 0000561955d52225 sp 00007fbaab8fe4a0 error 6 in plugin-container[561955d4d000+1b000]

comment:5 Changed 13 months ago by yawning

Resolution: wontfix
Status: newclosed

This project is deprecated, and none of these will ever be fixed.

Note: See TracTickets for help on using tickets.