#24122 closed defect (not a bug)

Firefox build in Tor Browser Bundle fails - how to see correct error message??

Reported by: gerbertb Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am trying to compile Tor Browser Bundle with tiny modification.

All i do is changing ONE IMAGE FILE in Tor Browser repository - icon of a browser. If i compile without my change, all is OK. If i compile chaning ONE IMAGE FILE (tor-browser/browser/branding/official/firefox.ico) - it fails.
And i can not understand how to debug it. The build log file is useless.
Please don't suggest to build just firefox. If i build just firefox (tor-browser) it finish just OK. Only if i build Tor Browser Bundle - it fails.

Please help me

How can i see CORRECT ERROR MESSAGE IN BUILD LOG? How can i debug Tor Browser Bundle build log of firefox?

The only information in build log is

make[3]: * [compile] Error 2
make[2]:
* [default] Error 2
make[1]: * [realbuild] Error 2
make:
* [build] Error 2

which is useless.

Full build log attached to ticket

Child Tickets

Attachments (1)

tbb_buildlog1_part1.txt (2.2 MB) - added by gerbertb 17 months ago.
part1 of build log

Change History (4)

Changed 17 months ago by gerbertb

Attachment: tbb_buildlog1_part1.txt added

part1 of build log

comment:1 Changed 17 months ago by gerbertb

Can not upload part2 and part3, it tells me i am spam and then captcha always error.

Here is paste with full log:
paste DOT ee/p/2q4Qw

Please replace DOT with ".". If i paste just URL, it tells me i am span and captcha error again.

comment:3 Changed 17 months ago by boklm

Resolution: not a bug
Status: newclosed

Because the build is running multiple jobs in parallel, the error is not at the bottom of the file.

You can find the error by searching for Error 1 in the log file:

i686-w64-mingw32-windres -O coff --use-temp-file -DNDEBUG=1 -DTRIMMED=1 -DXPCOM_GLUE -DMOZ_HAS_MOZGLUE -DAPP_VERSION=52.4.0 -DMOZ_PHOENIX '-DFIREFOX_ICO="/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/branding/firefox.ico"' '-DDOCUMENT_ICO="/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/branding/document.ico"' '-DNEWWINDOW_ICO="/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/branding/newwindow.ico"' '-DNEWTAB_ICO="/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/branding/newtab.ico"' '-DPBMODE_ICO="/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/branding/pbmode.ico"' --include-dir /var/tmp/build/firefox-aebc94b02253/browser/app --include-dir /var/tmp/build/firefox-aebc94b02253/obj-mingw/browser/app --include-dir /var/tmp/build/firefox-aebc94b02253/obj-mingw/build --include-dir /var/tmp/build/firefox-aebc94b02253/toolkit/xre --include-dir /var/tmp/build/firefox-aebc94b02253/xpcom/base --include-dir /var/tmp/build/firefox-aebc94b02253/xpcom/build --include-dir /var/tmp/build/firefox-aebc94b02253/security/sandbox/chromium --include-dir /var/tmp/build/firefox-aebc94b02253/security/sandbox/chromium-shim --include-dir /var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/include -o module.res /var/tmp/build/firefox-aebc94b02253/obj-mingw/browser/app/module.rc
make![5]: Leaving directory `/var/tmp/build/firefox-aebc94b02253/obj-mingw/browser/app'
/var/tmp/dist/mingw-w64/helpers/i686-w64-mingw32-gcc -std=gnu99 -mwindows -o /var/tmp/build/firefox-aebc94b02253/obj-mingw/security/nss/lib/util/nssilock.o -c -Os -mwindows -mms-bitfields  -DXP_PC -UDEBUG -DNDEBUG -DWIN32 -D_WINDOWS -DWIN95 -DNSS_DISABLE_LIBPKIX -DNSS_NO_INIT_SUPPORT -DUSE_UTIL_DIRECTLY -DNO_NSPR_10_SUPPORT -DSSL_DISABLE_DEPRECATED_CIPHER_SUITE_NAMES -I/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/include/nspr -I/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/include/nspr -I/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/include/nss -I/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/private/nss -mnop-fun-dllimport  -DNSS_ENABLE_TLS13_SHORT_HEADERS nssilock.c
i686-w64-mingw32-windres: icon file `/var/tmp/build/firefox-aebc94b02253/obj-mingw/dist/branding/firefox.ico' does not contain icon data
make![5]: *** [module.res] Error 1
make![4]: *** [browser/app/target] Error 2
make![4]: *** Waiting for unfinished jobs....
Note: See TracTickets for help on using tickets.