#24141 closed defect (duplicate)

consdiffmgr.c:329: cdm_diff_ht_purge: Non-fatal assertion

Reported by: cypherpunks Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.3-alpha
Severity: Normal Keywords: 031-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

 Error from LZMA encoder: Unable to allocate memory (5).
 NULL stream while compressing
 Error from LZMA encoder: Unable to allocate memory (5).
 NULL stream while compressing
 tor_bug_occurred_(): Bug: ../src/or/consdiffmgr.c:329: cdm_diff_ht_purge: Non-fatal assertion !((*diff)->entry == NULL) failed. (on Tor 0.3.2.3-alpha )
 Bug: Non-fatal assertion !((*diff)->entry == NULL) failed in cdm_diff_ht_purge at ../src/or/consdiffmgr.c:329. Stack trace: (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(log_backtrace+0x44) [0x562a0ed18014] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x562a0ed33159] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(consdiffmgr_rescan+0xd14) [0x562a0ecb1694] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(+0x5116f) [0x562a0ebe616f] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7fe4219cc5a0] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(do_main_loop+0x29d) [0x562a0ebe6eed] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(tor_main+0x1c25) [0x562a0ebea9f5] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(main+0x19) [0x562a0ebe26a9] (on Tor 0.3.2.3-alpha )
 Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7fe42042e2b1] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(_start+0x2a) [0x562a0ebe26fa] (on Tor 0.3.2.3-alpha )
 tor_bug_occurred_(): Bug: ../src/or/consdiffmgr.c:329: cdm_diff_ht_purge: Non-fatal assertion !((*diff)->entry == NULL) failed. (on Tor 0.3.2.3-alpha )
 Bug: Non-fatal assertion !((*diff)->entry == NULL) failed in cdm_diff_ht_purge at ../src/or/consdiffmgr.c:329. Stack trace: (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(log_backtrace+0x44) [0x562a0ed18014] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x562a0ed33159] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(consdiffmgr_rescan+0xd14) [0x562a0ecb1694] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(+0x5116f) [0x562a0ebe616f] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7fe4219cc5a0] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(do_main_loop+0x29d) [0x562a0ebe6eed] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(tor_main+0x1c25) [0x562a0ebea9f5] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(main+0x19) [0x562a0ebe26a9] (on Tor 0.3.2.3-alpha )
 Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7fe42042e2b1] (on Tor 0.3.2.3-alpha )
 Bug:     /usr/bin/tor(_start+0x2a) [0x562a0ebe26fa] (on Tor 0.3.2.3-alpha )
 Channel padding timeout scheduled 313494ms in the past.

possible duplicate of #24086

Child Tickets

Change History (4)

comment:1 Changed 23 months ago by nickm

Keywords: 031-backport added
Milestone: Tor: 0.3.2.x-final

comment:2 Changed 22 months ago by nickm

Owner: set to nickm
Status: newaccepted

comment:3 Changed 22 months ago by nickm

Yeah, it was indeed a duplicate of #24086, but the analysis wasn't easy. :)

comment:4 Changed 22 months ago by nickm

Resolution: duplicate
Status: acceptedclosed
Note: See TracTickets for help on using tickets.