Opened 11 months ago

Last modified 9 months ago

#24146 reopened defect

Linux Tor Browser 7.0.10 version: The proxy server is refusing connections

Reported by: TorontoBoy Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My tor browser auto-upgraded yesterday 2017 Friday Nov 03 to 7.0.9 but the restart gave me the error "The proxy server is refusing connections" for any URL. I cannot use the browser.

I'm on Ubuntu 16.04. How do I fix this issue. I normally do not change any of Tor's settings.

About Tor Borowser: 7.0.9 (based on Mozilla Firefox 52.4.1) (64-bit)

Any help to get Tor browser working again would be appreciated. Thank you.

Child Tickets

Change History (12)

comment:1 Changed 11 months ago by nickm

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:2 Changed 11 months ago by gk

Status: newneeds_information

What do you get as log if you start Tor Browser from the command line like so: ./start-tor-browser.desktop --debug in your Tor Browser directory?

comment:3 Changed 11 months ago by TorontoBoy

This is my terminal output, then Tor starts. Same message in Tor: The proxy server is refusing connections. I see no log created in the directory.

<code>
don-pc:~/.tor-browser-en/INSTALL$ ls
Browser start-tor-browser.desktop
don-pc:~/.tor-browser-en/INSTALL$ ./start-tor-browser.desktop --debug
Launching './Browser/start-tor-browser --detach --debug'...
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
1509831704200 addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232} WARN Loading extension '{73a6fe31-595d-460b-a920-fcc0f8843232}': Reading manifest: Error processing permissions.1: Unknown permission "privacy"
1509831704200 addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232} WARN Loading extension '{73a6fe31-595d-460b-a920-fcc0f8843232}': Reading manifest: Error processing permissions.4: Unknown permission "unlimitedStorage"
1509831704300 addons.webextension.https-everywhere-eff@… WARN Loading extension 'https-everywhere-eff@…': Reading manifest: Error processing devtools_page: An unexpected property was found in the WebExtension manifest.
1509831704600 addons.webextension.https-everywhere-eff@… WARN Please specify whether you want browser_style or not in your browser_action options.
Unable to update the static FcBlanks: 0x0600
Unable to update the static FcBlanks: 0x0601
Unable to update the static FcBlanks: 0x0602
Unable to update the static FcBlanks: 0x0603
Unable to update the static FcBlanks: 0x06dd
Unable to update the static FcBlanks: 0x070f
Unable to update the static FcBlanks: 0x2028
Unable to update the static FcBlanks: 0x2029
Unable to update the static FcBlanks: 0xfff9
Unable to update the static FcBlanks: 0xfffa
Unable to update the static FcBlanks: 0xfffb
</code>

comment:4 Changed 11 months ago by gk

So, Tor Browser does not start either Torbutton or Tor Launcher for some reason which explains your experience. Do you see the extensions on your about:addons page?

comment:5 Changed 11 months ago by TorontoBoy

about:addons include these, all enabled:
-HTTPS Ecerywhere
-NoScript
-Torbutton
-TorLauncher
-Adblock Plus

I disabled Adblock Plus yesterday, and today Tor browser is working. Today I re-enabled Adblock Plus, closed and then reopened Tor Browser, and after a 5 second delay Tor Browser started working again, and I can browse as normal.

Before today the green onion icon to the left of the address bar, the one to get a new identity or a new tor circuit, was missing. It has now returned. I do not know why, as I did not do any update since Tor browser would not work.

Anyway, my Tor Browser now works, but I still don't know why it stopped working. Should I not be using Adblock Plus on Tor Browser?

Thanks all for your help. Please close this thread.

comment:6 in reply to:  5 Changed 11 months ago by gk

Resolution: worksforme
Status: needs_informationclosed

Replying to TorontoBoy:

about:addons include these, all enabled:
-HTTPS Ecerywhere
-NoScript
-Torbutton
-TorLauncher
-Adblock Plus

I disabled Adblock Plus yesterday, and today Tor browser is working. Today I re-enabled Adblock Plus, closed and then reopened Tor Browser, and after a 5 second delay Tor Browser started working again, and I can browse as normal.

Before today the green onion icon to the left of the address bar, the one to get a new identity or a new tor circuit, was missing. It has now returned. I do not know why, as I did not do any update since Tor browser would not work.

Anyway, my Tor Browser now works, but I still don't know why it stopped working. Should I not be using Adblock Plus on Tor Browser?

It's not a tested combination and we generally advise against using adblockers. See: https://www.torproject.org/projects/torbrowser/design/#philosophy section 5. No filters for our reasoning. My first guess would be that Adblock indeed interfered with Torbutton/Tor Launcher which is kind of scary. But without steps to reproduce that's hard to say.

Thanks all for your help. Please close this thread.

You are welcome.

comment:7 Changed 11 months ago by TorontoBoy

Resolution: worksforme
Status: closedreopened
Summary: Linux 7.0.9 version: The proxy server is refusing connectionsLinux Tor Browser 7.0.10 version: The proxy server is refusing connections
Version: Tor: 0.3.1.8

Tor browser upgraded to 7.0.10, proxy server is again refusing all connections, browser completely unusable. I completely removed Adblock Plus plugin, so no other addon plugins. Reboote but Tor browser still does not work.

Torbutton and Torlauncher, usually the green onion icon to the left of the address bar, does not appear, so I cannot change tor circuits.

Any help would be appreciated. I guess I could delete Tor browser and reinstall?
Thank you all.

comment:8 in reply to:  7 Changed 11 months ago by gk

Keywords: linux ubuntu removed
Status: reopenedneeds_information
Version: Tor: 0.3.1.8

Replying to TorontoBoy:

Tor browser upgraded to 7.0.10, proxy server is again refusing all connections, browser completely unusable. I completely removed Adblock Plus plugin, so no other addon plugins. Reboote but Tor browser still does not work.

Torbutton and Torlauncher, usually the green onion icon to the left of the address bar, does not appear, so I cannot change tor circuits.

Any help would be appreciated. I guess I could delete Tor browser and reinstall?
Thank you all.

Are Torbutton and TorLauncher visible on about:addons? If so, are they activated? If not, can you activate them and restart Tor Browser?

comment:9 Changed 11 months ago by TorontoBoy

Torbutton and Torlauncher are visible in about:addons, but they are both disabled. There is no button to enable them, so I cannot activate them. Both only have a remove button. On a whim, from the "More" link for Torbutton I changed automatic updates from default to on. I left Torlauncher's automatic updates to default.

Just before I submitted this, about 5 minutes, the about:addons screen changed and both Torbutton and Torlauncher had a message that they will be available upon Tor browser restart. I restarted Tor browser and the two now appear activated, they display to the left of the address bar, and now Tor browser works properly.

What just happened? I just had Tor browser unusable for 3 days. Was my automatic defaults somehow set incorrectly? Is Tor browser stable?

Thanks for all your help.

comment:10 in reply to:  9 Changed 11 months ago by gk

Resolution: worksforme
Status: needs_informationclosed

Replying to TorontoBoy:

Torbutton and Torlauncher are visible in about:addons, but they are both disabled. There is no button to enable them, so I cannot activate them. Both only have a remove button. On a whim, from the "More" link for Torbutton I changed automatic updates from default to on. I left Torlauncher's automatic updates to default.

Well, Torbutton and Tor Launcher won't get any updates via the usual extension update mechanism. New versions are only shipped with Tor Browser. But still it is weird that you did not have the option to enabled both.

Just before I submitted this, about 5 minutes, the about:addons screen changed and both Torbutton and Torlauncher had a message that they will be available upon Tor browser restart. I restarted Tor browser and the two now appear activated, they display to the left of the address bar, and now Tor browser works properly.

Any idea what could have changed the about:addons screen?

What just happened? I just had Tor browser unusable for 3 days. Was my automatic defaults somehow set incorrectly? Is Tor browser stable?

It's hard to say what happened. All I know is that your report is the only one with that particular problem.

Thanks for all your help.

You are welcome. For the future you could start Tor Browser with ./start-tor-browser.desktop --debug --log which should give you a tor-browser.log file. It might contain some hints in case this happens again.

comment:11 Changed 9 months ago by kat5

Resolution: worksforme
Status: closedreopened

I saw similar behavior today with TB 7.0.11 on Ubuntu 14.0.4.

When the browser launched, I didn't see the circuit building dialog. The browser said it was TB, but also said it was Firefox, with the FF logo in the middle. Help > About said TB, but again, the logo was the FF logo.

about:addons showed no addons at all.

All connection attempts resulted in the "proxy server refusing connections" error.

This persisted through several browser restarts. About an hour later, everything started working fine again.

I will start running TB in debug mode in case this happens again.

comment:12 in reply to:  11 Changed 9 months ago by Me@…

Hello.
Just hope this is simple.
Open Add-ons Manager and Enable Torbutton and TorLauncher, and then everything will work again.

Have a really nice day, and hope this work.


Replying to kat5:

I saw similar behavior today with TB 7.0.11 on Ubuntu 14.0.4.

When the browser launched, I didn't see the circuit building dialog. The browser said it was TB, but also said it was Firefox, with the FF logo in the middle. Help > About said TB, but again, the logo was the FF logo.

about:addons showed no addons at all.

All connection attempts resulted in the "proxy server refusing connections" error.

This persisted through several browser restarts. About an hour later, everything started working fine again.

I will start running TB in debug mode in case this happens again.


Note: See TracTickets for help on using tickets.