#24151 closed enhancement (duplicate)

rip out everything related to DL_SCHED_DETERMINISTIC

Reported by: catalyst Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: refactor, s8-perf, technical-debt
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor8

Description

It looks like the only code that uses DL_SCHED_DETERMINISTIC is testing code. We should rip out all code related to it. This will make it easier to refactor in the future and reduce the binary size by eliminating dead code.

Child Tickets

Change History (2)

comment:1 Changed 18 months ago by nickm

Duplicate of #23354 ? I'm okay to take that in 0.3.3 if so

comment:2 Changed 18 months ago by catalyst

Resolution: duplicate
Status: newclosed

Oops, sorry. Yes, it looks like mostly a duplicate of #23354. Posted some updates there.

Note: See TracTickets for help on using tickets.