Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#24164 closed defect (not a bug)

errors I get after I installed 0.3.2.3 on my relay

Reported by: Dbryrtfbcbhgf Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get the below errors when I install the latest alpha on my relay.
14:45:28.000 [notice] Tor 0.3.2.3-alpha (git-d36fb2a6d1b7e75f) opening log file.

14:45:28.316 [warn] OpenSSL version from headers does not match the version we're running with. If you get weird crashes, that might be why. (Compiled with 1000207f: OpenSSL 1.0.2g-fips 1 Mar 2016; running with 1000207f: OpenSSL 1.0.2g 1 Mar 2016).

14:45:28.316 [warn] Can't get entropy from getrandom().

Child Tickets

Change History (9)

comment:1 Changed 2 years ago by nickm

Milestone: Tor: 0.3.2.x-final

comment:2 Changed 2 years ago by dgoulet

Huh, can you provide your kernel version? Seems that the package was compiled with SYS_getrandom but yet the system doesn't have getrandom().

Are you using the deb.torproject.org packages or the one from your system?

comment:3 Changed 2 years ago by dgoulet

Status: newneeds_information

comment:4 in reply to:  2 ; Changed 2 years ago by Dbryrtfbcbhgf

Replying to dgoulet:

Huh, can you provide your kernel version? Seems that the package was compiled with SYS_getrandom but yet the system doesn't have getrandom().

Are you using the deb.torproject.org packages or the one from your system?

Kernel 2.6.32 and I’m using the packages from deb.torproject.org.

comment:5 in reply to:  4 ; Changed 2 years ago by dgoulet

Replying to Dbryrtfbcbhgf:

Replying to dgoulet:

Huh, can you provide your kernel version? Seems that the package was compiled with SYS_getrandom but yet the system doesn't have getrandom().

Are you using the deb.torproject.org packages or the one from your system?

Kernel 2.6.32 and I’m using the packages from deb.torproject.org.

Ok, you must be using some newer Ubuntu packages than 10.04 Lucid which is End Of Life btw :S.

So yeah this is not surprising and unfortunately not much we can do about it because the package you use it not meant for Lucid and thus assumes things that the system doesn't have.

comment:6 Changed 2 years ago by nickm

Resolution: worksforme
Status: needs_informationclosed

comment:7 in reply to:  5 Changed 2 years ago by Dbryrtfbcbhgf

Resolution: worksforme
Status: closedreopened

Replying to dgoulet:

Replying to Dbryrtfbcbhgf:

Replying to dgoulet:

Huh, can you provide your kernel version? Seems that the package was compiled with SYS_getrandom but yet the system doesn't have getrandom().

Are you using the deb.torproject.org packages or the one from your system?

Kernel 2.6.32 and I’m using the packages from deb.torproject.org.

Ok, you must be using some newer Ubuntu packages than 10.04 Lucid which is End Of Life btw :S.

So yeah this is not surprising and unfortunately not much we can do about it because the package you use it not meant for Lucid and thus assumes things that the system doesn't have.

Im running Ubuntu 16.04.3 LTS (GNU/Linux 2.6.32-042stab120.11 x86_64) and I still get the errors on Tor 0.3.2.5-alpha

 [WARN] Can't get entropy from getrandom().

  [WARN] OpenSSL version from headers does not match the version we're running with. If you get weird crashes, that might be why. (Compiled with 1000207f: OpenSSL

   1.0.2g-fips 1 Mar 2016; running with 1000207f: OpenSSL 1.0.2g 1 Mar 2016).

Here is my relay https://atlas.torproject.org/#details/5D86AFD7CE409251E67B373B4F0E780A0F41C944

Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:8 Changed 2 years ago by dgoulet

Resolution: not a bug
Status: reopenedclosed

You will _always_ see that warning with a kernel on 2.6.32, it doesn't have get_random() syscall but yet you are using a package or a tor compiled with its support.

As long as you run tor not built for the system you are running it, you'll get these issues.

comment:9 in reply to:  8 Changed 2 years ago by arma

Replying to dgoulet:

You will _always_ see that warning with a kernel on 2.6.32, it doesn't have get_random() syscall but yet you are using a package or a tor compiled with its support.

As long as you run tor not built for the system you are running it, you'll get these issues.

I've opened #24500 for us to do something about the log message.

Note: See TracTickets for help on using tickets.