Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#2421 closed defect (fixed)

Torbutton Exception in sandbox evaluation., Date hooks not applied: TypeError: (void 0) is undefined

Reported by: valdis Owned by: mikeperry
Priority: Immediate Milestone:
Component: Applications/Torbutton Version: Torbutton: 1.3.0-alpha
Severity: Normal Keywords:
Cc: Actual Points: 1
Parent ID: #2465 Points: 1
Reviewer: Sponsor:

Description

Linux x86_64 Fedora Rawhide, Firefox 4.0b10pre from last night.

On each URL I visit while torbutton is active, I get several popups that each say:

Torbutton Exception in sandbox evaluation., Date hooks not applied:
TypeError: (void 0) is undefined

It appears that one is produced for each GET/POST request needed to render the page. Hitting https://check.torproject.org results in 3 popups, and the Javascript console contains:

[01-20 19:16:36] Torbutton WARN: Hook exception at: https://check.torproject.org/, TypeError: (void 0) is undefined
[01-20 19:16:37] Torbutton WARN: Hook exception at: https://check.torproject.org/, TypeError: (void 0) is undefined
[01-20 19:16:42] Torbutton WARN: Hook exception at: https://check.torproject.org/, TypeError: (void 0) is undefined

(Interestingly enough, the Javascript Error Console seems to think these are "messages" rather than "warnings", as they only appear at "All" and "Messages" levels,not at "Warnings".

I admit not having ruled out a conflict with other add-ons - will post follow-up if I identify one.

Child Tickets

Change History (12)

comment:1 Changed 9 years ago by valdis

It doesn't necessarily generate exactly 3 popups hitting check.torproject.org - I just got 7 or 8 (probably due to the cache being cleared and more hits occurring for CSS files, favico, etc).

However, it was still doing it with all other extensions disabled except for 'Add-on Compatibility Reporter', which I (a) can't easily disable because I'm running 4.0b10pre, and (b) is a pretty low-likelihood cause of problems.

comment:2 Changed 9 years ago by rransom

Priority: normalblocker

comment:3 Changed 9 years ago by rransom

<katmagic> I can't reproduce #2421 with Firefox 4.0b9 with Torbutton 1.3.1-alpha on Fedora 14.

katmagic downloaded Mozilla's Firefox 4.0b9 package to test this.

comment:4 Changed 9 years ago by valdis

Good catch, rramsom. Using the Fedora Rawhide version:

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9) Gecko/20110114 Firefox/4.0b9

it works.

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110119 Firefox/4.0b10pre

is broken. Thanks for catching that, now to figure out what caused the regression. Searching the Mozilla bugzilla, I'm not finding anything obviously relevant for 'sandbox', 'TypeError' or '(void 0)' opened in the last 2-3 weeks.

Blargh. This is going to be non-fun to get fixed, I can tell already.

comment:5 Changed 9 years ago by valdis

Narrowed down some more:

Checked as good:
ftp://ftp.mozilla.org/pub/firefox/nightly/2011/01/2011-01-11-03-mozilla-central/
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110111 Firefox/4.0b10pre
ID:20110111030357

Checked as bad:
ftp://ftp.mozilla.org/pub/firefox/nightly/2011/01/2011-01-12-03-mozilla-central/
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110112 Firefox/4.0b10pre
ID:20110112033217

comment:6 Changed 9 years ago by Valeryan_24

Hello,

Same thing on Ubuntu Natty alpha 64 bits, with Torbutton 1.3.1 alpha and Firefox 4.0b10 from official Ubuntu repositories, or Firefox 4.0b11 from Mozilla ppa - https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa - and all other addons disabled.

http://pix.toile-libre.org/upload/original/1296403710.png

comment:7 Changed 9 years ago by valdis

We've narrowed it down to a Firefox API change introduced by the fix for bug #612025 - the sandbox API got changed and Torbutton needs updating to the new world order. Mike Perry has a test .xpi that seems to fix this issue, but apparently has other sandbox API issues still.

comment:8 Changed 9 years ago by mikeperry

Parent ID: #2465

comment:9 Changed 9 years ago by mikeperry

Points: 1

comment:10 Changed 9 years ago by mikeperry

Resolution: fixed
Status: newclosed

This issue has been fixed in origin/master. The fix will appear in 1.3.2-alpha.

Bug #2465 still needs to be addressed though.

comment:11 Changed 9 years ago by mikeperry

Actual Points: 1
actualpointsdone: 1
pointsdone: 1

comment:12 Changed 2 years ago by teor

Severity: Normal

Set all tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.