Opened 4 weeks ago

Closed 4 weeks ago

#24262 closed defect (fixed)

hs-v3: Change "hsdir-interval" to "hsdir_interval" to match the spec

Reported by: dgoulet Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs, easy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We've merged the consensus param used by HS v3 in dir-spec.txt (#24118). They all follow some sort of common naming convention using underscores instead of hyphens.

The hsdir-interval is the only one in the code not following this. It is in get_time_period_length()

Child Tickets

Change History (6)

comment:1 Changed 4 weeks ago by dgoulet

Status: newmerge_ready

Branch: bug24262_032_01

(Trivial one liner, putting in merge_ready.)

comment:2 Changed 4 weeks ago by nickm

Looks okay! Should we backport this to earlier branches, or does this not affect hsdirs?

comment:3 in reply to:  2 Changed 4 weeks ago by dgoulet

Replying to nickm:

Looks okay! Should we backport this to earlier branches, or does this not affect hsdirs?

Oh phrack, I really thought this was an 032 thing but actually it was released in 031...

So yes, definitely backporting to 031 would be ideal. I can provide a 031 branch if needed, just ask.

comment:4 Changed 4 weeks ago by nickm

Yes, please!  Also, please update the "bugfix on " version in the changes file.

comment:5 Changed 4 weeks ago by dgoulet

See branch: bug24262_031_01

comment:6 Changed 4 weeks ago by nickm

Resolution: fixed
Status: merge_readyclosed

merged to 0.3.1 and forward!

Note: See TracTickets for help on using tickets.