Opened 2 years ago

Closed 2 years ago

#24272 closed defect (duplicate)

Add a CacheDirectory option

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.3.1.1-alpha
Severity: Normal Keywords: tor-relay, consensus-diff, tor-mobile
Cc: Actual Points:
Parent ID: #22703 Points: 2
Reviewer: Sponsor:

Description (last modified by teor)

Tor puts a large number of large, rapidly changing documents in its DataDirectory, which defaults to /var/lib on many systems. This means that the size of backups blows out when running tor 0.3.1.1-alpha or later.

If we added a CacheDirectory option, it could default to /var/cache (or the appropriate paths on other operating systems), and be ignored by most backup tools.

This directory should contain

  • cached directory documents, including cached (micro)descriptors and consensuses, and compressed directory document diffs
  • any other files that tor can easily regenerate or re-download

This might also benefit mobile users with small disks, but application size appears to be less of a priority for mobile developers than CPU or network usage.

This is a breaking change for tools that expect to find consensuses in the data directory. Perhaps we should make CacheDirectory default to DataDirectory instead?

See this thread for background:
https://lists.torproject.org/pipermail/tor-relays/2017-November/013542.html

Child Tickets

Change History (5)

comment:1 Changed 2 years ago by teor

Description: modified (diff)

comment:2 Changed 2 years ago by Sebastian

See also #24268

comment:3 Changed 2 years ago by nickm

Parent ID: #22703

comment:4 Changed 2 years ago by nickm

Owner: set to nickm
Status: newaccepted

comment:5 Changed 2 years ago by nickm

Resolution: duplicate
Status: acceptedclosed

Closing as duplicate of #22703, which now has code for review

Note: See TracTickets for help on using tickets.