Opened 14 years ago

#243 closed defect (Not a bug)

Privoxy not required in Firefox 1.5

Reported by: locksmith9 Owned by: phobos
Priority: Low Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: locksmith9 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The doc located at http://tor.eff.org/cvs/tor/doc/tor-doc-win32.html suggests using Firefox, but does not mention that you do not need to install Privoxy if all you want to do is soxify DNS requests. Recommend adding the following additional help for those that may choose. Privoxy is a good app for scrubbing HTML code, but it also adds another step and complicates the install for newbies. The below may make things a touch simpler:

If you have at least Firefox 1.5, type the following into the address bar:

about:config

Scroll down to setting

network.proxy.socks_remote_dns

and change the value to true.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (5)

comment:1 Changed 14 years ago by cakruege

works for me

comment:2 Changed 14 years ago by cakruege

ps: works for Thunderbird, too.

You need about:config for Thunderbird:
http://aboutconfig.mozdev.org/installation.html

comment:3 Changed 14 years ago by phobos

Yes, you are correct. However, using privoxy with Firefox 1.5 defaults will work as well. The simplest, common solution
works for those non-technical users that don't want to understand SOCKS or mess with about:config.

comment:4 Changed 14 years ago by phobos

I should add, we're happy to accept documentation on how to do this for Firefox/Thunderbird 1.5 as well.

comment:5 Changed 14 years ago by phobos

flyspray2trac: bug closed.

Note: See TracTickets for help on using tickets.