Opened 11 months ago

Closed 8 weeks ago

#24312 closed defect (implemented)

Update DirCache Warning

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Minor Keywords: tor-log, easy, intro, review-group-32, 034-triage-20180328, 034-removed-20180328
Cc: Actual Points:
Parent ID: Points: 0.1
Reviewer: teor Sponsor:

Description

When DirCache is disabled tor 0.3.1.x says:

[warn] DirCache is disabled and we are configured as a relay. This may disqualify us from becoming a guard in the future.

Since TorBrowser ships tor 0.3.1.x we can consider this as granted (not in the future), right?

Child Tickets

Change History (17)

comment:1 Changed 11 months ago by dgoulet

Resolution: not a bug
Status: newclosed

"tor" in Tor Browser aren't relays so this warning can't be showed with Tor Browser.

Only relays can get this warning if the available memory is >= 300MB and DirCache 0.

comment:2 Changed 11 months ago by cypherpunks

Resolution: not a bug
Status: closedreopened

Hi David,

I think there is a misunderstanding. This ticket is not about showing a warning to Tor Browser users.

This ticket is about the fact that tor (relay) says:

This may disqualify us from becoming a guard in the future.

, but it should say:

This disqualifies us from becoming a guard.

or am I wrong about this?

comment:3 Changed 9 months ago by teor

Keywords: tor-log easy intro added
Milestone: Tor: 0.3.4.x-final
Points: 0.1
Severity: NormalMinor

comment:4 Changed 8 months ago by teor

This warning only applies to Tor client versions 0.3.1, 0.3.2, and 0.3.3.
0.2.5 and 0.2.9 will still choose non-DirCache relays as guards.
And I authorities will still flag non-DirCache relays as guards.

So I suggest we say "Some client versions will not choose us as a guard."

comment:5 Changed 8 months ago by cypherpunks

I'd say
"Most client versions will not choose us as a guard."
since most use Tor Browser as the client (which runs a current version of tor)?

comment:6 Changed 8 months ago by teor

Whoever writes the patch can choose the exact wording.

comment:7 Changed 8 months ago by minik

I think I created the patch correctly. Please let me know if this looks right. I pulled down my own repo and just added a patch like before... so hopefully the version of tor I did the patch on was the most recent.

https://github.com/ingoglia/tor_tickets/tree/bug24312

comment:8 Changed 8 months ago by cypherpunks

you use:
"Many client versions will not choose us as a guard. "

I'd say that operator mostly do not care about how many different versions of client
will not choose us as a guard but how many of the overall clients (client fraction),
so maybe lets use:

"Most tor clients will not us as a guard."
What do you think?

comment:9 Changed 8 months ago by teor

Status: reopenedneeds_review

I've marked this as "needs review", someone will review the ticket in the next week or two.
It's up to you if you want to revise the message before then.

comment:10 Changed 8 months ago by nickm

Keywords: review-group-32 added

comment:11 Changed 8 months ago by teor

Reviewer: teor
Status: needs_reviewneeds_revision

There is an extra space at the end of the log message.
Please also consider revising the wording.

comment:12 Changed 7 months ago by nickm

Keywords: 034-triage-20180328 added

comment:13 Changed 7 months ago by nickm

Keywords: 034-removed-20180328 added

Per our triage process, these tickets are pending removal from 0.3.4.

comment:14 Changed 6 months ago by nickm

Milestone: Tor: 0.3.4.x-finalTor: unspecified

These needs_revision, tickets, tagged with 034-removed-*, are no longer in-scope for 0.3.4. We can reconsider any of them, if somebody does the necessary revision.

comment:15 Changed 8 weeks ago by teor

Milestone: Tor: unspecifiedTor: 0.3.5.x-final
Status: needs_revisionneeds_review

Please see my branch bug24312-master on https://github.com/teor2345/tor.git

We can backport this fix if we'd like, but since it just removes "in the future" from a log message, I'm not sure it's worth it.

comment:17 Changed 8 weeks ago by nickm

Resolution: implemented
Status: needs_reviewclosed

looks fine; merged it! Agree about not needing a backport.

Note: See TracTickets for help on using tickets.