Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#24316 closed defect (not a bug)

Tor Browser doesn't filter ads anymore?

Reported by: cypherpunks Owned by: tbb-team
Priority: Very Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser includes uBlock Origin. But TBB version 7.0.10 doesn't display the uBlock Origin button in the toolbar anymore. Furthermore, ads seem to not being blocked anymore. What's going on?

Child Tickets

Change History (11)

comment:1 Changed 2 months ago by boklm

Resolution: not a bug
Status: newclosed

Tor Browser does not include uBlock Origin. See #17569 for discussion about adding uBlock Origin.

comment:2 Changed 2 months ago by cypherpunks

Resolution: not a bug
Status: closedreopened

Wait, what?! Why do I see uBlock Origin on the extensions list of TBB's add-on manager? It has been there since a while (it's an official TBB, no crap downloaded somehow somewhere). With TBB 7.0.10, it's still there in the extensions list but the button in the toolbar has disappeared as well as blocking ads has. On major websites, ads are being displayed now. So again, what's changed?

comment:3 Changed 2 months ago by boklm

uBlock Origin was never included in Tor Browser by default. It's possible that you installed yourself the extension. Although I don't know why it stopped working.

comment:4 in reply to:  2 Changed 2 months ago by pastly

Resolution: not a bug
Status: reopenedclosed

Replying to cypherpunks:

Wait, what?! Why do I see uBlock Origin on the extensions list of TBB's add-on manager?

You're probably using Tails. The Tails developers added uBlock Origin to the Tor Browser that they ship.

comment:5 Changed 2 months ago by cypherpunks

You're probably using Tails.

Ah, okay! Are there any Tails people hanging around over here available helping clarify this issue?

comment:7 Changed 2 months ago by cypherpunks

uBlock Origin was never included in Tor Browser by default. By using Tails' TBB, you agree to be identified differently than us who use official Tor Browser. Uninstall that default and always support OFFICIAL TBB.

comment:8 Changed 2 months ago by cypherpunks

Priority: HighVery Low

comment:9 Changed 2 months ago by gk

uBlock should still work if users want to install it for whatever reason in Tor Browser. If that's not the case and is happening outside of a Tails context, please reopen the bug with steps to reproduce the problem.

comment:10 Changed 2 months ago by cypherpunks

(this is indeed Tails specific and ublock works outside of the way it's installed in Tails, so this should remain closed but for completeness:

On Tails it seems to be related to the version of ublock shipped with debian stretch, installing it from the debian sid repos during the build process seems to resolve this issue, at least in my test build...)

comment:11 in reply to:  7 Changed 2 months ago by arma

Replying to cypherpunks:

always support OFFICIAL TBB.

While we're being complete: it's Tor Browser, not Tor Browser Bundle, and has been this way for years. The reason is that it's now just a browser with some extensions (which means e.g. that the browser update feature can update the whole thing).

Note: See TracTickets for help on using tickets.