#24322 closed defect (duplicate)

make IPv6-only clients bootstrap without needing config changes.

Reported by: dkg Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords: IPv6
Cc: Actual Points:
Parent ID: #17835 Points:
Reviewer: Sponsor:

Description

#17281 suggests that an IPv6-only client should be able to bootstrap by setting some flags in torrc. I've done:

ClientUseIPv4 0
ClientUseIPv6 1

But, most clients are not *always* IPv4-only or IPv6-only. In particular, i tend to move my laptop between networks that have different properties (i'm writing this from a v6-only network).

I shouldn't have to fiddle with my torrc to make tor work. it should be able to auto-detect this situation and do the right thing automatically.

Child Tickets

Change History (1)

comment:1 Changed 22 months ago by teor

Parent ID: #17835
Resolution: duplicate
Status: newclosed
Version: Tor: 0.3.1.8

Hi dkg,

This is a duplicate of #17835 and #17217. (There are a lot of tickets about IPv6 support in Tor.)

You can see the relevant section of the IPv6 roadmap here:

https://trac.torproject.org/projects/tor/wiki/org/roadmaps/Tor/IPv6Features#ClientConnectiontoEntryNodes

The next task I am working on is #20916, because consensus changes take a while to deploy to all the authorities. I suspect we might also need to improve IPv6 support on relays before we can make clients use IPv6 by default, as only 20% of relays have IPv6 ORPorts.

Note: See TracTickets for help on using tickets.