#24358 closed defect (invalid)

flex error 32 linux build??? binutils

Reported by: fedora0penchaos@… Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

gcc -DHAVE_CONFIG_H -I. -I. -I./../include -I./../elfcpp -DLOCALEDIR="\"/var/tmp/dist/binutils/share/locale\"" -DBINDIR="\"/var/tmp/dist/binutils/bin\"" -DTOOLBINDIR="\"/var/tmp/dist/binutils/x86_64-unknown-linux-gnu/bin\"" -DTOOLLIBDIR="\"/var/tmp/dist/binutils/x86_64-unknown-linux-gnu/lib\"" -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Werror -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -frandom-seed=yyscript.o -g -O2 -MT yyscript.o -MD -MP -MF .deps/yyscript.Tpo -c -o yyscript.o yyscript.c
yyscript.c:1:1: error: return type defaults to 'int' [-Werror=return-type]
yyscript.c:1:1: error: function declaration isn't a prototype [-Werror=strict-prototypes]
cc1: all warnings being treated as errors
make[4]: * [yyscript.o] Error 1
make[4]:
* Waiting for unfinished jobs....
mv -f .deps/workqueue.Tpo .deps/workqueue.Po
mv -f .deps/stringpool.Tpo .deps/stringpool.Po
mv -f .deps/symtab.Tpo .deps/symtab.Po
make[4]: Leaving directory `/var/tmp/tmp.rWHRJpScJi/binutils-2.24/gold'
make[3]: * [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/tmp.rWHRJpScJi/binutils-2.24/gold'
make[2]:
* [all] Error 2
make[2]: Leaving directory `/var/tmp/tmp.rWHRJpScJi/binutils-2.24/gold'
make[1]: * [all-gold] Error 2
make[1]: Leaving directory `/var/tmp/tmp.rWHRJpScJi/binutils-2.24'
make:
* [all] Error 2

(What I got when building 32 bits linux Tor-Browser)
I guess it is flex, so there needs to be flex library inside the container or my system?

Child Tickets

Change History (6)

comment:1 Changed 22 months ago by gk

Cc: boklm added
Component: Applications/Tor bundles/installationApplications/Tor Browser
Keywords: tbb-rbm added; rbm-build removed
Owner: changed from erinn to tbb-team

comment:2 Changed 22 months ago by boklm

I don't have this error. Which commit are you using, and did you make any change in tor-browser-build before getting this error?

comment:3 Changed 22 months ago by boklm

Status: newneeds_information

comment:4 Changed 22 months ago by fedora0penchaos@…

I am using commit eec1680 (tor browser build)
and (latest) commit 236fcaa (rbm)

comment:5 Changed 22 months ago by boklm

Did you modify anything in tor-browser-build?

By the way eec1680 is old. Is there a reason for using that commit?

comment:6 Changed 22 months ago by boklm

Resolution: invalid
Status: needs_informationclosed

This is probably caused by some changes you made. Please reopen if it happens with unmodified tor-browser-build.

Note: See TracTickets for help on using tickets.