Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2436 closed defect (wontfix)

Front Page of Wiki Not Editable

Reported by: dougransom Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Thereby breaking the usefuless of the wiki.

I'd like to add a link to https://trac.torproject.org/projects/tor/wiki/TheOnionRouter/ListOfDotOnionHiddenServices from the wiki front page

Child Tickets

Change History (4)

comment:1 Changed 8 years ago by phobos

Resolution: wontfix
Status: newclosed

Correct, it is not editable. This is by design. Every other page is editable. We don't want to host a list of all hidden services.

comment:2 Changed 7 years ago by proper

Resolution: wontfix
Status: closedreopened

(I don't care about "ListOfDotOnionHiddenServices", I care about editing the wiki main page.)

Design by technology or design by policy?

It's being said, that people are watching out for malicious edits. [1] Also there are no big problems with malicious edits yet?

The wiki start page barely gets any updates. And contributors don't get motivated, if they can't link their content. People added lots of useful content to the wiki which becomes dust after a while, because there is no reference on the main page. Also missing the edit button on the start page might someone make think for the whole wiki: "only admins are encourages to edit pages".

At least registered editors should be allowed to edit that site.

[1] https://lists.torproject.org/pipermail/tor-talk/2012-February/023007.html

comment:3 Changed 7 years ago by phobos

Resolution: wontfix
Status: reopenedclosed

It's by policy. As the history shows, most people don't edit the start page in helpful ways. And this means I end up taking care of it. This means cleaning out the spam, child porn, hidden wiki clone attempts, removing the dead links and projects, and other useless junk. I don't have time to babysit the main page and answer questions about why tor is advertising (insert one of the four horsemen of the infopocalypse here). Trac doesn't allow for levels of editing so we cannot have moderators with permission to edit some pages where others cannot. We're stuck with the binary edit or not current state.

I agree with others who want to separate trac/bugtracking from a tor community wiki. The majority of people who read through the wiki think everything is officially written by Tor and therefore our policy/opinion.

comment:4 Changed 7 years ago by proper

Write down your rules. Grow a community. Get more moderators.

The current state of the wiki is a big mess. You discussed this, no progress. I offer to contribute.

Look at TitleIndex. There are loads of articles which are not linked on the wiki main page. It also demonstrates that there are enough serious and helpful contributors. Most pages are now out of date because barely anyone notices them.

Intermediate solution:
Can you please copy the source from WikiStart and paste it in WikiStartAlternate (or any other name you decide).

I am going to revise the start page. Incorporate all articles which are already somewhere lost and spread in the wiki.

And if you like the result, it may be copied back to WikiStart.

Note: See TracTickets for help on using tickets.