Opened 13 months ago

Closed 13 months ago

Last modified 7 months ago

#24382 closed defect (fixed)

I resized my terminal window and nyx crashed.

Reported by: Dbryrtfbcbhgf Owned by: atagar
Priority: High Milestone:
Component: Core Tor/Nyx Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I resized my terminal window and nyx crashed. Here is the traceback.

Traceback (most recent call last):

  File "/usr/local/bin/nyx", line 11, in <module>

    sys.exit(main())

  File "/usr/local/lib/python3.5/dist-packages/nyx/__init__.py", line 176, in main

    nyx.starter.main()

  File "/usr/local/lib/python3.5/dist-packages/stem/util/conf.py", line 289, in wrapped

    return func(*args, config = config, **kwargs)

  File "/usr/local/lib/python3.5/dist-packages/nyx/starter.py", line 118, in main

    nyx.curses.start(nyx.draw_loop, acs_support = config.get('acs_support', True), transparent_background = True, cursor = False)

  File "/usr/local/lib/python3.5/dist-packages/nyx/curses.py", line 217, in start

    curses.wrapper(_wrapper)

  File "/usr/lib/python3.5/curses/__init__.py", line 94, in wrapper

    return func(stdscr, *args, **kwds)

  File "/usr/local/lib/python3.5/dist-packages/nyx/curses.py", line 215, in _wrapper

    function()

  File "/usr/local/lib/python3.5/dist-packages/nyx/__init__.py", line 245, in draw_loop

    interface.redraw(force = not key.is_null())

  File "/usr/local/lib/python3.5/dist-packages/nyx/__init__.py", line 716, in redraw

    panel.redraw(force = force, top = occupied)

  File "/usr/local/lib/python3.5/dist-packages/nyx/panel/__init__.py", line 175, in redraw

    self._last_draw_size = nyx.curses.draw(self._draw, top = self._top, height = self.get_height(), draw_if_resized = draw_dimension)

  File "/usr/local/lib/python3.5/dist-packages/nyx/curses.py", line 740, in draw

    curses_subwindow = CURSES_SCREEN.subwin(subwindow_height, subwindow_width, top, left)

_curses.error: curses function returned NULL

Child Tickets

Change History (2)

comment:1 Changed 13 months ago by atagar

Resolution: fixed
Status: newclosed

Thanks Dbryrtfbcbhgf! Another great catch. I can't reliably repro fix but pushed a fix that should address it...

https://gitweb.torproject.org/nyx.git/commit/?id=c0276f9

comment:2 Changed 7 months ago by saper

I have almost filed a dupe of this, maybe we could have 2.0.5 with that fix out?

Note: See TracTickets for help on using tickets.