Opened 5 months ago

Closed 5 months ago

#24413 closed defect (duplicate)

circuit_package_relay_cell(): Bug: outgoing relay cell sent from ../src/or/relay.c:839 has n_chan==NULL. Dropping. (on Tor 0.3.1.8 )

Reported by: alecmuffett Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

  • This error, repeatedly, on 0.3.1.7 and 0.3.1.8
  • I don't know if it happened on other versions.
  • Ubuntu 16.04.3 LTS with the Tor-supplied binaries;
  • Debian-Jessie, ditto
Nov 26 11:26:01.000 [warn] circuit_package_relay_cell(): Bug: outgoing relay cell sent from ../src/or/!relay.c:839 has n_chan==NULL. Dropping. (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug: . Stack trace: (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(log_backtrace+0x42) [0x555f99ba1242] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(relay_send_command_from_edge_+0x4ff) [0x555f99aa87ff] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(connection_edge_send_command+0x62) [0x555f99aa8ae2] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(connection_edge_package_raw_inbuf+0x1df) [0x555f99aa8def] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(connection_edge_process_inbuf+0x1df) [0x555f99b459df] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(+0x107f39) [0x555f99b3df39] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(+0x4d38e) [0x555f99a8338e] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x819) [0x7f932471b4c9] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(do_main_loop+0x295) [0x555f99a844b5] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(tor_main+0x1c35) [0x555f99a87f65] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(main+0x19) [0x555f99a7fcc9] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     /lib/x86_64-linux-gnu/libc.so.6(!__libc_start_main+0xf0) [0x7f932363a830] (on Tor 0.3.1.8 )
Nov 26 11:26:01.000 [warn] Bug:     tor(_start+0x29) [0x555f99a7fd19] (on Tor 0.3.1.8 )

Configuration:

DataDirectory /home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d
ControlPort unix:/home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d/tor-control.sock
PidFile /home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d/tor.pid
Log notice file /home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d/tor.log
SafeLogging 1
HeartbeatPeriod 60 minutes
LongLivedPorts 80,443
RunAsDaemon 1

# use single onions
SocksPort 0 
HiddenServiceSingleHopMode 1 
HiddenServiceNonAnonymousMode 1 

# softmap
HiddenServiceDir /home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d
HiddenServicePort 80 unix:/home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d/port-80.sock
HiddenServicePort 443 unix:/home/ubuntu/eotk/projects.d/wikipedia.d/hs-1.d/port-443.sock
HiddenServiceNumIntroductionPoints 3

Child Tickets

Change History (1)

comment:1 Changed 5 months ago by cypherpunks

Resolution: duplicate
Status: newclosed

Hi Alec! o/

Duplicate of #8185.

Note: See TracTickets for help on using tickets.