Opened 10 months ago

#24419 new enhancement

Improve getter names for boolean fields

Reported by: karsten Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:


From #21827:

The method name getRecommendedVersion is quite misleading - especially together with getVersion - as it returns a boolean not a version value, but as the method was introduced long ago this shouldn't halt a merge.

Maybe, the naming could be improved at some point?

So, what should we rename here? All boolean/Boolean fields in docs package classes to isXY()?

Anything else?

Child Tickets

Change History (0)

Note: See TracTickets for help on using tickets.