Opened 8 weeks ago

Closed 5 weeks ago

#24428 closed defect (fixed)

bootstrap error message sometimes lost

Reported by: brade Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Normal Keywords: TorBrowserTeam201712R
Cc: catalyst, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor4

Description

If another STATUS_CLIENT message is received on the control port while Tor Launcher is displaying an error, the error message is replaced with a status message. This was reported in ticket:24367#comment:15.

To avoid this problem, we plan to ignore STATUS_CLIENT messages when Tor Launcher is in "error display" mode.

Child Tickets

Attachments (1)

tor-and-tor-launcher-log.txt (3.7 KB) - added by brade 8 weeks ago.

Download all attachments as: .zip

Change History (7)

Changed 8 weeks ago by brade

comment:1 Changed 8 weeks ago by brade

The attachment I just added includes both tor and Tor Launcher logging. Notice that a STATUS_CLIENT NOTICE message is received after the STATUS_CLIENT WARN message. We are working on a patch for Tor Launcher.

comment:2 Changed 8 weeks ago by brade

Keywords: TorBrowserTeam201711R added; TorBrowserTeam201711 removed
Status: newneeds_review

comment:3 in reply to:  2 ; Changed 7 weeks ago by gk

Status: needs_reviewneeds_information

Replying to brade:

Here is a fix:
https://gitweb.torproject.org/user/brade/tor-launcher.git/commit/?h=bug24428-01&id=2cc63c03e1c67e2db71e581db1f6ca17cb75bcd1

Thanks, do you have some easy STR for me to check what happens without the patch and make sure your patch actually fixes this bug?

comment:4 Changed 7 weeks ago by gk

Keywords: TorBrowserTeam201712R added; TorBrowserTeam201711R removed

Moving review tickets over to December

comment:5 in reply to:  3 Changed 7 weeks ago by mcs

Status: needs_informationneeds_review

Replying to gk:

Thanks, do you have some easy STR for me to check what happens without the patch and make sure your patch actually fixes this bug?

It is a little tricky to reproduce because the bug is timing-dependent, so you may need to try several times. And note that Kathy and I only reproduced it on OSX (but I think catalyst saw it on Linux). That said, here are some STR:

  1. Start with a clean Tor Browser that uses the new Tor Launcher UI, e.g., 7.5a8.
  2. Set you system clock forward; Kathy and I used 24 or 25 hours but catalyst saw the bug with a +3.5 hour offset.
  3. Start Tor Browser and click Connect.

If the bug occurs, you will see a stalled progress bar after a while with a bold progress message such as "Loading relay information." The bold font is an indication that an error message was displayed and then replaced with a regular bootstrap progress message.

comment:6 Changed 5 weeks ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good. Applied to master as commit c4f55f9f2c29caad1270ece1bc723d22d0996f3e.

Note: See TracTickets for help on using tickets.