#24510 closed enhancement (duplicate)

Make AccountingStart begin at the same time each period

Reported by: andrewtoth Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #10307 Points:
Reviewer: Sponsor:

Description

My ISP provides me with unlimited bandwidth for a certain time window each day. I would like to use AccountingStart day to start my relay at the beginning of that window. However, from the FAQ:

Note that your relay won't wake up exactly at the beginning of each accounting period. It will keep track of how quickly it used its quota in the last period, and choose a random point in the new interval to wake up.

How can I configure my relay to ignore this feature and begin at the specified time each day?

Child Tickets

Change History (1)

comment:1 Changed 21 months ago by teor

Component: - Select a componentCore Tor/Tor
Milestone: Tor: unspecified
Parent ID: #10307
Resolution: duplicate
Status: newclosed

This is a duplicate of https://trac.torproject.org/projects/tor/ticket/10307#comment:6

To get your relay to run at certain times, you can use a control port script to adjust RelayBandwidthRate (or AccountingMax).

Check out stem at https://stem.torproject.org/ , or search github for scripts people have written.

Note: See TracTickets for help on using tickets.