#24568 closed defect (duplicate)

I get a warn error every time I build tor from source

Reported by: Dbryrtfbcbhgf Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get a warn error every time I build tor from source. I'm running macOS and using Xcode 9.2

Tor 0.3.2.6
'''src/or/rendservice.c:1910:29: warning: comparison of integers of different signs: 'ssize_t' (aka 'long') and 'size_t' (aka 'unsigned long') [-Wsign-compare]'''

    parsed_req->ciphertext, MIN(parsed_req->ciphertext_len, keylen),

'''                            ^   ~~~~~~~~~~~~~~~~~~~~~~~~~~  ~~~~~~'''

'''/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.13.sdk/usr/include/sys/param.h:215:23: note: '''expanded from macro 'MIN'

#define MIN(a,b) (((a)<(b))?(a):(b))

Child Tickets

Change History (1)

comment:1 Changed 11 months ago by nickm

Resolution: duplicate
Status: newclosed

Thanks for reporting this! I think it is a duplicate of #24480.

Note: See TracTickets for help on using tickets.