Opened 10 months ago

Closed 8 months ago

#24578 closed enhancement (duplicate)

about:tbupdate popup notification formatting error

Reported by: mrphs Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by mrphs)

Please see the attached screen shot. I noticed the information shown in the popup notification of the about:tbupdate needs some better formatting.

It shows the address as about:tbupdate?https%3A%2F%2....

I just updated to 7.0.11 not sure if this existed before or not.


Additionally, as you can see the Firefox logo both in the popup box and beside the url needs to be replaced with TB logo.

Child Tickets

Attachments (1)

about-tb-update-popup-notification.png (217.1 KB) - added by mrphs 10 months ago.

Download all attachments as: .zip

Change History (5)

Changed 10 months ago by mrphs

comment:1 Changed 10 months ago by mrphs

Description: modified (diff)

comment:2 Changed 10 months ago by gk

Cc: mcs brade added

comment:3 Changed 9 months ago by mcs

I do not think this is a new problem. We do plan to stop using a query parameter with about:tbupdate (#21850 is a related ticket). Then the doorhanger would just have about:tbupdate.

The wrong icon is shown on all of our about: pages, e.g., about:tor so that is general branding problem.

comment:4 in reply to:  3 Changed 8 months ago by mcs

Resolution: duplicate
Status: newclosed

Replying to mcs:

I do not think this is a new problem. We do plan to stop using a query parameter with about:tbupdate (#21850 is a related ticket). Then the doorhanger would just have about:tbupdate.

The above issue is fixed by the patches in #21850.

The wrong icon is shown on all of our about: pages, e.g., about:tor so that is general branding problem.

I am resolving this ticket as a duplicate of #10888 because it covers this remaining issue.

Note: See TracTickets for help on using tickets.