Opened 11 months ago

Closed 7 weeks ago

#24592 closed defect (worksforme)

Tor Browser crashes on Motherboard website

Reported by: cypherpunks Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB crashes at motherboard.vice.com/en_ca

This sometimes happens only occasionally. Today I noticed this site causing regular crashing of TBB when viewing content opened in tabs from home page.

On crashing console shows:

[Child 25286] WARNING: pipe error (17): Connection reset by peer: file /home/debian/build/tor-browser/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
[Child 25286] WARNING: pipe error (3): Connection reset by peer: file /home/debian/build/tor-browser/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322

###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x3E0003,name=PCompositable::Msg_Destroy) Channel error: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x8E0001,name=PLayer::Msg___delete__) Channel error: cannot send/recv

[Child 25286] ###!!! ABORT: Aborting on channel error.: file /home/debian/build/tor-browser/ipc/glue/MessageChannel.cpp, line 2152
[Child 25286] ###!!! ABORT: Aborting on channel error.: file /home/debian/build/tor-browser/ipc/glue/MessageChannel.cpp, line 2152

Followed by segfault.

Even if I can avoid the crash, closing the browser after viewing the website shows in console:

windows.onRemoved event fired after context unloaded.
[Parent 25385] WARNING: pipe error: Broken pipe: file /home/debian/build/tor-browser/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 685
[Parent 25385] WARNING: pipe error (46): Connection reset by peer: file /home/debian/build/tor-browser/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322

So the browser process segfaults "Aborting on channel error". I try to avoid loading this site with other tabs open.

Child Tickets

Change History (4)

comment:1 Changed 11 months ago by gk

Keywords: tbb-crash added
Priority: MediumHigh
Severity: NormalMajor
Status: newneeds_information

Works for me. Do you feel you could try to follow the debugging steps on our HACKING document and come back with a stack trace from your crashes? See: https://trac.torproject.org/projects/tor/wiki/doc/TorBrowser/Hacking#Usinggdb.

comment:2 Changed 7 weeks ago by traumschule

Resolution: fixed
Status: needs_informationclosed

Can't reproduce it with 8.0.2.

comment:3 Changed 7 weeks ago by traumschule

Resolution: fixed
Status: closedreopened

Correct resolution

comment:4 Changed 7 weeks ago by traumschule

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.