#24601 closed defect (worksforme)

CollecTor directory listing apparently breaks when a directory in recent/ runs dry

Reported by: karsten Owned by: metrics-team
Priority: Low Milestone:
Component: Metrics/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The CollecTor directory listings on Tor Metrics broke at or shortly after 2017-12-11 13:08:

https://metrics.torproject.org/collector/recent/relay-descriptors/server-descriptors/

The index.json file looks okay right now:

https://collector.torproject.org/index/index.json

I suspect the reason is that some of the directories in recent/ containing sanitized bridge descriptors ran dry yesterday afternoon. Maybe we ran into a NullPointerException or something.

Child Tickets

Change History (3)

comment:1 Changed 22 months ago by iwakeh

Is there any logging about this incident? And, what does the 'broken' listing look like?

comment:2 Changed 22 months ago by karsten

Priority: MediumLow

There is no log, AFAIK.

The listing is broken in the sense that it stopped being updated. Well, I should write was broken, because it's fixed again, probably due to a server restart for #24602, entirely unrelated to this ticket.

We might still be able to reproduce this issue by feeding a modified index.json file, say, without any bridge descriptors into the servlet. Just to avoid future occurrences.

I realize that this is now a rather weak bug report with just an idea for reproducing, the error being gone, and the error not being the end of the world. Setting priority to low.

comment:3 Changed 21 months ago by karsten

Resolution: worksforme
Status: newclosed

Alright, I tried to reproduce this issue locally with a modified index.json file and failed. Let's close this ticket and handle this issue if/when it shows up again.

Note: See TracTickets for help on using tickets.