Opened 8 months ago

Closed 8 months ago

#24624 closed defect (fixed)

tbb-logo.svg may cause network access

Reported by: mcs Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Normal Keywords: TorBrowserTeam201712R
Cc: tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor4

Description

While working on other areas of Tor Launcher, Kathy and I noticed what looked like an attempt by Tor Browser to access www.w3.org. It seems to be caused by this line within tbb-logo.svg, which we should remove (it is not needed and most of the SVGs that are part of Firefox omit it):

<!DOCTYPE svg PUBLIC "-W3CDTD SVG 1.1EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

Child Tickets

Change History (2)

comment:1 Changed 8 months ago by mcs

Keywords: TorBrowserTeam201712R added; TorBrowserTeam201712 removed
Status: newneeds_review

comment:2 Changed 8 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Fixed with commit c22a773ffaeb0398d8be0119f6e89f3c8161e4aa on master, thanks.

Note: See TracTickets for help on using tickets.