Opened 6 months ago

Closed 4 months ago

#24639 closed defect (duplicate)

After I updated my relay to Tor 0.3.2.7-rc I got a large amount of Warn errors

Reported by: Dbryrtfbcbhgf Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #25061 Points:
Reviewer: Sponsor:

Description

After I updated my relay to Tor 0.3.2.7-rc I got a large amount of Warn errors.

 │ 13:29:26 [NOTICE] Performing bandwidth self-test...done. 


 │ 13:28:45 [NOTICE] Bootstrapped 100%: Done 


 │ 13:28:45 [NOTICE] Tor has successfully opened a circuit. Looks like client functionality is working. 


 │ 13:28:45 [WARN]  6 connections died in state handshaking (TLS) with SSL state SSLv2/v3 read server hello A in HANDSHAKE ''' [4 duplicates hidden]'''


 │ 13:28:45 [WARN]  106 connections died in state connect()ing with SSL state (No SSL object) 


 │ 13:28:45 [WARN] 112 connections have failed: 


 │ 13:28:45 [WARN] Problem bootstrapping. Stuck at 90%: Establishing a Tor circuit. (Connection timed out; TIMEOUT; count 14; recommendation warn; host


 │   5CF8AFA5E4B0BB88942A44A3F3AAE08C3BDFD60B at 178.16.208.62:443) ''' [94 duplicates hidden]'''


 │ 13:28:45 [WARN]  105 connections died in state connect()ing with SSL state (No SSL object) 


 │ 13:28:45 [WARN] 111 connections have failed: 


 │ 13:28:45 [WARN]  104 connections died in state connect()ing with SSL state (No SSL object) 


 │ 13:28:45 [WARN] 110 connections have failed: 


 │ 13:28:44 [WARN]  103 connections died in state connect()ing with SSL state (No SSL object) 


 │ 13:28:44 [WARN] 109 connections have failed: 


 │ 13:28:44 [WARN]  102 connections died in state connect()ing with SSL state (No SSL object) 


 │ 13:28:44 [WARN] 108 connections have failed: 


 │ 13:28:43 [NOTICE] Bootstrapped 90%: Establishing a Tor circuit 


 │ 13:28:42 [NOTICE] Bootstrapped 85%: Finishing handshake with first hop 


 │ 13:28:42 [NOTICE] Bootstrapped 80%: Connecting to the Tor networ


rk 

 │ 13:28:40 [WARN]  5 connections died in state handshaking (TLS) with SSL state SSLv2/v3 read server hello A in HANDSHAKE ''' [59 duplicates hidden]'''

 │ 13:28:40 [WARN]  93 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 98 connections have failed: 

 │ 13:28:40 [WARN]  92 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 97 connections have failed: 

 │ 13:28:40 [WARN]  91 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 96 connections have failed: 

 │ 13:28:40 [WARN]  90 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 95 connections have failed: 

 │ 13:28:40 [WARN]  89 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 94 connections have failed: 

 │ 13:28:40 [WARN]  88 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 93 connections have failed: 

 │ 13:28:40 [WARN]  87 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 92 connections have failed: 

 │ 13:28:40 [WARN]  86 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 91 connections have failed: 

 │ 13:28:40 [WARN]  85 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 90 connections have failed: 

 │ 13:28:40 [WARN]  84 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 89 connections have failed: 

 │ 13:28:40 [WARN]  83 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 88 connections have failed: 

 │ 13:28:40 [WARN]  82 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 87 connections have failed: 

 │ 13:28:40 [WARN]  81 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 86 connections have failed: 

 │ 13:28:40 [WARN]  80 connections died in state connect()ing with SSL state (No SSL object) 

 │ 13:28:40 [WARN] 85 connections have failed: 

─┘ 13:28:40 [WARN]  79 connections died in state connect()ing with SSL state (No SSL obj

Child Tickets

Change History (5)

comment:1 Changed 5 months ago by teor

Milestone: Tor: 0.3.3.x-final
Parent ID: #24902
Priority: HighMedium
Severity: MajorNormal

There has been extra client load on the network since December.
Your relay probably chose two guards that were overloaded.
It will eventually try other guards.

What version were you on before?

comment:2 in reply to:  1 Changed 5 months ago by Dbryrtfbcbhgf

Replying to teor:

There has been extra client load on the network since December.
Your relay probably chose two guards that were overloaded.
It will eventually try other guards.

What version were you on before?

I think the previous version was Tor 0.3.2.6.

comment:3 Changed 5 months ago by arma

I think this is #25061.

comment:4 Changed 5 months ago by teor

Parent ID: #24902#25061

comment:5 Changed 4 months ago by dgoulet

Resolution: duplicate
Status: newclosed

Executive decision to try to shrink down the 033 tickets, I'm calling this a duplicate of #25061 and also pointing out that #24767 might help the bootstrap as well if tor does try multiple time to the same unreachable relay.

I'll keep the parent for future ref if needed.

Note: See TracTickets for help on using tickets.