Opened 2 years ago

Closed 21 months ago

#24643 closed defect (duplicate)

ValueError: invalid literal for int() with base 10: 'johan36'

Reported by: johan36 Owned by: qbi
Priority: Medium Milestone:
Component: Internal Services/Service - trac Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

How to Reproduce

While doing a POST operation on /newticket, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'__FORM_TOKEN': u'78fe85b76ec3f7f02589c339',
 u'action': u'create',
 u'field_actualpoints': u'',
 u'field_cc': u'support',
 u'field_component': u'- Select a component',
 u'field_description': u'Hi.\r\nI did update/download this new browser version: 7.0.7.\r\nIt seemed to work well when I surfing on the net.\r\nBut later when I ran my virus protection program, the antivirus program announced that it had found the Trojan virus (W32/App.a3470959d2!)\r\nIN Tor Browser:707 FILE and after that the antivirus program put the Trojan into quarantine immediately. \r\nNever before there has been any problems with viruses when I used the Tor Browser, did this Trojan horse come with the New Tor browser?\r\nOr did it come from some website and hiding now in the Tor Browser file?\r\nBecause when I destroyed it, it come back in to the Tor Browser folder.\r\nI ran my Antivirus program again and placed it in quarantine. \r\nDo I dare to use this new version of the browser anymore?\r\nIs it safe?\r\n\r\nRegards\r\njohan',
 u'field_keywords': u'Tor 7.0.7, Trojan, Virus, Worm, Backdoor',
 u'field_milestone': u'Tor: unspecified',
 u'field_parent': u'johan36',
 u'field_points': u'',
 u'field_priority': u'Immediate',
 u'field_reviewer': u'johan',
 u'field_severity': u'Critical',
 u'field_sponsor': u'',
 u'field_summary': u'Tor Browser 7.0.7 with Trojan horse?',
 u'field_type': u'defect',
 u'field_version': u'Tor: unspecified',
 u'preview': u'Preview',
 u'sfp_email': u'',
 u'sfph_mail': u''}

User agent: Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Interface Customization

Interface customization information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 613, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 253, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/dist-packages/trac/ticket/web_ui.py", line 178, in process_request
    return self._process_newticket_request(req)
  File "/usr/lib/python2.7/dist-packages/trac/ticket/web_ui.py", line 522, in _process_newticket_request
    valid = valid and self._validate_ticket(req, ticket)
  File "/usr/lib/python2.7/dist-packages/trac/ticket/web_ui.py", line 1378, in _validate_ticket
    for field, message in manipulator.validate_ticket(req, ticket):
  File "build/bdist.linux-x86_64/egg/childtickets/childtickets.py", line 69, in validate_ticket
    pid = int(ticket.values.get('parent').lstrip('#'))
ValueError: invalid literal for int() with base 10: 'johan36'

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by teor

Component: - Select a componentInternal Services/Service - trac
Owner: set to qbi

comment:2 Changed 21 months ago by qbi

Resolution: duplicate
Status: newclosed

duplicate of #18872

Note: See TracTickets for help on using tickets.